Unofficial Plugin Repo for 0.5 Sardaukar, 1.0 Kralizec, 2.0 Stoneburner, 3.0 Erasmus, 4.0 Arrakis

  • Cups is already in the pipeline by tekkbebe, but the same procedure as for minidlna applies there, don't ask for ETAs.


    Greetings
    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!

  • Updated OMV wiki entry for the Plugins.


    http://wiki.openmediavault.org/index.php?title=Plug-ins


    Greetings
    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!

  • This should make a lot of you happy. Transmission has been ported by forum member subzeroin. Excellent work on his part. It hasn't had extensive testing but is available in the repo now.

    omv 5.5.11 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I don't use it so I don't know. It is transmission 2.75. I will try and update to current (2.82) in the next few days.

    omv 5.5.11 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • At first I would like to THANK YOU for your effort preparing these plugins for all OMV users!


    At second I would like to please you to convert Website plugin to be compatible with Sardaukar (I know, tousands different users, thousands different wishes. As I saw at present it's the Autoshutdown plugin which is being converted) :) . I would like to remove my 2 disks from my nas and put them to my OMV machine, but I need a webserver.


    THANK YOU one more time :!:

  • Quote from "ryecoaaron"

    Made transmission 2.82 package here and libevent 2.0.21 here. Please test because I don't use it.


    I wgetted these and installed with dpkg -i.


    Restarted transmission, but when I click About in the transmissions normal webgui (/transmission/web/) it still shows Transmission 2.75 (13675).


    So it doesnt seem as if the version is updated?

  • Hi,


    I have a question surrounding the plugin removal / "cleanup" / upgrade (0.4 -> 0.5) / re-install (either new 0.5 plugin or manual if unavailable)..


    (I'm thinking here primarily MySQL however general question across the board)


    Will user data and/or configuration settings persist through this process? For example, I have one OMV box dedicated to Sabnzbd/CouchPotato/Sickbeard and MySQL (for XBMC backend) setup and while in theory I could upgrade to 0.5 (making use of a manual MySQL install) would I have to backup my configurations (everything) and data (MySQL) prior to upgrade then restore or would the data be protect? Or, asked in a different way, is the 'incompatibility' limited just to the plug-in interface within the OMV web frontend or indeed to the underlying apps?


    Thanks, Simon

  • MySQL should be unaffected but can sometimes be removed when the plugin is removed. The incompatibility is really the web interface. I would either make a good backup of your system using Clonezilla and try it or stay with 0.4. Right now, there is probably little benefit of moving to 0.5.

    omv 5.5.11 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Quote from "ryecoaaron"

    MySQL should be unaffected but can sometimes be removed when the plugin is removed. The incompatibility is really the web interface. I would either make a good backup of your system using Clonezilla and try it or stay with 0.4. Right now, there is probably little benefit of moving to 0.5.


    Thanks for the reply / good advice. I am indeed likely to stay with 0.4 - was simply curious as to how "do-able" such an upgrade was (like you say the minimal benefit is not really worth the effort/risk at the moment).

  • Quote from "ryecoaaron"

    MySQL should be unaffected but can sometimes be removed when the plugin is removed. The incompatibility is really the web interface. I would either make a good backup of your system using Clonezilla and try it or stay with 0.4. Right now, there is probably little benefit of moving to 0.5.


    If I'm not mistaken MySQL would only be removed if it's marked as automatically installed. As it will be if it been installed as a dependency on openmediavault-mysql. But that's is easily resolved by running


    Code
    apt-get install mysql-server


    and then


    Code
    apt-get remove openmediavault-mysql


    I think purge will work too, but then all configs in OMV for the plugin will be removed. You could always test the commands by adding -s to apt-get to see what it'll do.

  • I didn't know if he used jhmiller's script to install mysql or used the plugin to install it. If he used the script, he would be fine. Like you said, if it was installed with the plugin, it would uninstalled.

    omv 5.5.11 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • What did I steal? If I removed copyrights, it is because I did so unintentionally or changed it completely. I apologize if I did and will add it wherever needed. Just let me know where. Very sorry

    omv 5.5.11 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!