Why my installation for virtualbox only shows 32-bits option ?

  • Hi Sir,

    I login to phpVirtualBox interface and try to install new vm images, but "Create Virtual Machine" only has 32-bits dropdown list.
    My PC board has 64 bit capabilities with Intel CPU. I also open Virtualization inside BIOS. My PC runs Win7 Ultimate 64-bits OS w/32MB RAM.

    I used VirtualBox Windows version to setup openmediavualt debian (64-bits) image and run that images. Inside this images I installed virtualbox extras and I wanted to install a new virtualbox image inside this openmediavault extras package (virtualbox), everything went smoothly but why dropdown list only show 32-bits options ? I should expect to see 64-bits and 32-bits list, am I right ??

    Windows 7 Ultimate => Debian 9 (64-bits) => openmediavaults => extras => virtualbox extras => Create Virtual Machine => Version dropdown xxx 32-bits only ????


    • Official Post

    Other than the fact you are using nested virtualization with Virtualbox (meaning you will double the performance penalty), your install of Virtualbox on Windows is not passing the proper CPU flags to the virtual machine that are required to virtualize a 64bit machine. I haven't used virtualbox on Windows in years to know if you can do this or not. Why are you not just creating additional VMs on the Windows install of Virtualbox?

    omv 7.4.2-2 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.14 | compose 7.2.1 | k8s 7.2.0-1 | cputemp 7.0.2 | mergerfs 7.0.5 | scripts 7.0.8

    omv-extras.org plugins source code and issue tracker - github - changelogs

    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • This is just a 32/64 bit issues. There are another issue I still have problem.

    Such as I logined into phpVirtualBox web management interface ( ), and tried to install a new virtual machine, after put windows_xp.iso and start VM, I saw a small window showed up this vm (on right-up corner) was running and asked me to start to format this disk. I cannot connect to this vm. I used vnc tried to connect to this running installation vm without luck.

    GUI mouse point and it showed vnc:// (this vm network using NAT), how can I connect console or gui to this new installing vm ?

    I tried to use VNC to (openmediavault host ip) too. Also not working !

    Switch network to HOST BRIDGE NETWORK still not working for vnc connecting to console.

    No keyboard and screen to allow me to finish windows xp installation.

    Any idea of how to use vnc to connect to running vm image ?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!