backup plugin - exclude "/home" dir?

  • hi,


    I am using the OMV also as a simple desktop and therfore have a rather large /home directory on the /dev/sda1, which is also the root partition.


    when I am using the backup pluing - which is great - with the option fsarchiver the whole /home directory will be backed up, which is unnecessary and a waste of hdd space.


    Is there any way to exlude some dirs from backup when using fsarchiver?


    a solution 1would be to move the /home to a separte partition ... I know :) but I don't have a fixed partition size for /root and /home.


    thx & best

  • I guess I could expose the extra options box for fsarchiver as well. This would allow you to specify excludes parameters.


    That said, if you enable home directories on OMV, the home directories will be in a shared folder on a data drive avoiding this issue. The concept of OMV is to have no data on the OS drive so that if you lose the OS drive, you lose no data.


    While I use home directories at /home as well, if you have so much data that it is wasting space, you are doing it wrong. That much info should be on the data drives.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I know... I know :) I just sync dropbox to /home thats a lot of data but I don't need an backup of my dropbox data.


    I would highly appreciate if you could expose the extra options box for fsarchiver. It could be uaeful for a lot of things.


    thx! +1

  • 4.0.6 is in the repo now. I just tested with --exclude=/home and it worked fine.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • works great - only there is a typo in the default exclude options " --excloude=/srv " - one "o" to much :)


    I would exclude "/mnt" as well...


    thx!

  • only there is a typo in the default exclude options " --excloude=/srv " - one "o" to much

    There are no default options. That must be your typo :)


    I would exclude "/mnt" as well...

    This shouldn't be necessary. fsarchiver and dd backup the partition only. rsync includes the one filesystem flag and excludes /mnt already. So, none of three would backup files if another filesystem was mounted on/in /mnt or any other mountpoint.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • interessting... after updating the backup plugin via apt-get I had the following exlude options already there. I thougt they were the default settings :)


    --exclude=/home --exclude=/tmp --exclude=/export --exclude=/srv --exclude=/lost+found

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!