Can't browse CIFS shares until I login to OMV and wake it up

  • Running OMV 4.x for a month or two. Plex and Duplicati running well. Done some preliminary searches of these forums to find the answer to this - but it's not apparent.

    I find that when I try and browse folders that are available on my internal home network, my local Windows 10 machine tells me that my OMV server is unavailable - even though it's up and running. I then login to the OMV control panel and hit either my disks or folder shares - which "wakes up the disks" and then the shares are browse-able via Windows and I'm up and running.

    My disks are set to spin-down after 30 minutes - which seems reasonable. But I can't seem to wake things up without logging into the control panel.

    I'm assuming that the answer has something to do with WOL, but when I dig into it - it doesn't make sense to me.

    Appreciate any suggestions.

  • If you're not shutting down or suspending, WOL shouldn't be a consideration.
    Setting WOL aside, there are still a number of factors: OMV 3 or 4. And there's the hardware involved and what it supports. (The Mobo, hard drives models, are drives connected by USB?, etc.)

    Have you tired the different disk power management profiles? If you shorten the spindown time, to 5 minutes, you should be able to run some quick tests.


  • So nothing has really changed here. If I browse the server, I'm told it's not available. If I ping the server approximately 3 times - literally ping it via a command prompt - that I can browse the server with Windows Explorer from the same machine.

    Since the server is awake - and up and running, I'm assuming that pinging it wakes up the drives.

    Is this a choice between never putting the drives to sleep vs allowing them to spin down? Is there a way to wake up the drives without pinging the server?

    Thanks for your suggestion.

  • Is there a way to wake up the drives without pinging the server?

    I find it interesting that ping or web access wakes drives up, but SMB share access (ports 139 and 445) doesn't. Have you looked at power settings in your servers BIOS? If trying to use power saving features in the OS, I wouldn't use them in BIOS. The two may interact in odd ways. Beyond that, I don't know what to tell you. Have you tried 192- intermediate power usage without spin down?

    If you want to investigate this further, look at the output of hdparm -I /dev/sda
    Under capabilities and features, you can look at what your drives support.
    Here's a good -> list of hdparm commands and some practical examples.
    (BTW, looking at capabilities and features is one thing, but changing hard drive settings on the CLI may not be a good idea.)

    I don't spin my drives down. For the most part, I use server shares everyday. Given the surge of current it takes to start any motor and the wear and tear involved in a motor start up, I let mine spin. With multiple daily accesses and a client backup server running, there probably isn't much of a difference in watts used, if startup surge current is accounted for.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!