Drive unmountable

  • Hi all,


    New to OMV - I have one HD installed so far but after a reboot or two it wouldn't mount, having worked fine before. Searched the forums, couldn't fix, so reformatted, renamed and now back in business.


    But - the old drive name is still referenced in file systems and marked as n/a and missing. I'd like to remove this entry - how can I?


    Thanks, John

    Inwin MS04 case with 315 W PSU

    ASUS Prime H310i-Plus R2.0 board

    Two port PCI-E SATA card

    16GB Kingston DDR4

    Intel Pentium Coffee Lake G5400 CPU

    Samsung Evo M.2 256GB OS drive

    4x4TB WD Red NAS drives + 1x4TB + 1x5TB Seagate drives - MergerFS pool

    Seagate 5TB USB drives - SnapRAID parity x 2

    • Official Post

    It would have been nice if you could simply delete the entry for a drive that has been removed, and then everything that depends on that drive is automatically deleted. But OMV doesn't allow that... Some form of precaution?


    To remove the drive entry you need to first delete everything that involves that drive. You have to first delete any entry for services that use or reference that drive, then any entry for shares that use that drive, then any entry for filesystems that use that drive. It may seem complicated, but it is just the direct reverse of what you did after you added the drive.

    Be smart - be lazy. Clone your rootfs.
    OMV 5: 9 x Odroid HC2 + 1 x Odroid HC1 + 1 x Raspberry Pi 4

  • Thanks this did the trick.

    Inwin MS04 case with 315 W PSU

    ASUS Prime H310i-Plus R2.0 board

    Two port PCI-E SATA card

    16GB Kingston DDR4

    Intel Pentium Coffee Lake G5400 CPU

    Samsung Evo M.2 256GB OS drive

    4x4TB WD Red NAS drives + 1x4TB + 1x5TB Seagate drives - MergerFS pool

    Seagate 5TB USB drives - SnapRAID parity x 2

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!