502 Bad Gateway nginx

  • 502 Bad Gateway nginx


    updated from version 3 to version 4
    web interface has stopped working



    Code
    root@storage:~# dpkg -l | grep openm
    ii openmediavault 4.1.27-1 all openmediavault - The open network attached storage solution
    ii openmediavault-keyring 1.0 all GnuPG archive keys of the OpenMediaVault archive
    ii openmediavault-nut 4.0.13-1 all OpenMediaVault Network UPS Tools (NUT) plugin
    Code
    omv-firstaid
    ERROR: Failed to connect /var/lib/openmediavault/engined.sock: [Errno 2] No such file or directory
  • It seems your installation is broken, some required packages are not installed, althought they are declared as dependency on the OMV package.


    Fix that by running


    Bash
    # apt-get install php-mbstring

    I assume this will not really fix your issue because there might be other packages missing.

  • getting it

  • /var/log/php/ - no directory



    php7.0-fpm.log

    Code
    [22-Nov-2019 14:39:44] NOTICE: Terminating ...
    [22-Nov-2019 14:39:44] NOTICE: exiting, bye-bye!
    [22-Nov-2019 14:39:44] NOTICE: fpm is running, pid 12013
    [22-Nov-2019 14:39:44] NOTICE: ready to handle connections
    [22-Nov-2019 14:39:44] NOTICE: systemd monitor interval set to 10000ms
  • Code
    2019/11/23 09:09:25 [error] 53449#53449: *1 FastCGI sent in stderr: "PHP message: PHP Fatal error: Uncaught Error: Class 'DOMDocument' not found in /usr/share/php/openmediavault/config/databasebackend.inc:110
    Stack trace:
    #0 /usr/share/php/openmediavault/config/database.inc(34): OMV\Config\DatabaseBackend->load()
    #1 /usr/share/php/openmediavault/config/database.inc(44): OMV\Config\Database->__construct()
    #2 /usr/share/php/openmediavault/env.inc(42): OMV\Config\Database::getInstance()
    #3 /var/www/openmediavault/index.php(24): require_once('/usr/share/php/...')
    #4 {main}
    thrown in /usr/share/php/openmediavault/config/databasebackend.inc on line 110" while reading response header from upstream, client: 127.0.0.1, server: openmediavault-webgui, request: "HEAD / HTTP/1.1", upstream: "fastcgi

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!