Internal Server Error

  • Hi all, I am a newbie and just installed OMV5. Everything seemed to install fine and I can get into the webgui no issues. I can make some changes through the web control panel but also encountering problems with other settings. For example, if I attempt to enable SMB/CIFS, I get the an internal server error as follows:



    {"response":null,"error":{"code":0,"message":"The property 'localmaster' does not exist in the model 'conf.service.smb'.","trace":"OMV\\AssertException: The property 'localmaster' does not exist in the model 'conf.service.smb'. in \/usr\/share\/php\/openmediavault\/config\/configobject.inc:71\nStack trace:\n#0 \/usr\/share\/php\/openmediavault\/config\/configobject.inc(186): OMV\\Config\\ConfigObject->assertExists('localmaster')\n#1 \/usr\/share\/php\/openmediavault\/config\/configobject.inc(271): OMV\\Config\\ConfigObject->set('localmaster', true, true)\n#2 \/usr\/share\/php\/openmediavault\/config\/configobject.inc(233): OMV\\Config\\ConfigObject->setFlatAssoc(Array, true, false)\n#3 \/usr\/share\/openmediavault\/engined\/rpc\/smb.inc(81): OMV\\Config\\ConfigObject->setAssoc(Array)\n#4 [internal function]: Engined\\Rpc\\Smb->setSettings(Array, Array)\n#5 \/usr\/share\/php\/openmediavault\/rpc\/serviceabstract.inc(123): call_user_func_array(Array, Array)\n#6 \/usr\/share\/php\/openmediavault\/rpc\/rpc.inc(86): OMV\\Rpc\\ServiceAbstract->callMethod('setSettings', Array, Array)\n#7 \/usr\/sbin\/omv-engined(537): OMV\\Rpc\\Rpc::call('SMB', 'setSettings', Array, Array, 1)\n#8 {main}"}}



    I have re-installed OMV5 but still getting the same issues.


    Any help would be greatly appreciated.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!