No network interface after Clean install of OMV 4 and no root access

  • I've done a clean install of OMV (version 4.1.22-1) on a wiped unformatted sata M.2 SSD without any error messages, but in the end I have 2 problems.
    Previously, I have had OMV 3.99 running without problems.


    During installation I have left the root password to default (openmediavault)
    I have created a user account 'willem'
    After installation and first boot I get the message "no network interface(s) available".
    However, during the installation was a connection for updating Debian available.
    I've tried ipt addr and I got a message I don't understand.


    2nd problem is I can't log on as root with the default username and password.



    What am I to do to fix it?
    The network device is not broken, because I have run a trail version of Ubuntu 18.04 from USB stick without changing the hardware setup and I get internet access.

    Motherboard: ASRock H270M-ITX/ac
    Processor: Intel Pentium G4500
    Memory: 1x Kingston ValueRam 8GB(1x8GB) DDR4 2133MHz CL1
    System Drive: SANDISK 128 GB SSD X400 M.2
    Data Drives: 4x Seagate NAS 3TB
    Case: Fractal Design Node 304
    Power: Be quiet! PURE POWER 10 400W CM
    UPS: Eaton Ellipse ECO 1600


    OMV version: 4.1.31-1

    Edited 2 times, last by JukeboxBill ().

  • you need to login as root with the password you set during the installation. The default user and pass given is for the web interface which you obviously can't get to.


    You should login as root and then address your network problem. I would try the omv-firstaid command first. Once you get the network working, you can get to the web interface and login with the default credentials.

  • With your help , I managed to log on in root. Yesterday night I have tried to set up the network via omv-firstaid, but could not get it going.
    Because I have 2 network connections on my NAS I was not sure which one I was configuring, so I have now tried with both connected to my router and after reboot of the NAS I had a connection, even without using omv-firstaid.


    So, I'm up and running again :D

    Motherboard: ASRock H270M-ITX/ac
    Processor: Intel Pentium G4500
    Memory: 1x Kingston ValueRam 8GB(1x8GB) DDR4 2133MHz CL1
    System Drive: SANDISK 128 GB SSD X400 M.2
    Data Drives: 4x Seagate NAS 3TB
    Case: Fractal Design Node 304
    Power: Be quiet! PURE POWER 10 400W CM
    UPS: Eaton Ellipse ECO 1600


    OMV version: 4.1.31-1

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!