How to adjust APM level (-B) and deploy so that GUI doesn't change it back?

  • Having trouble with APM. 4 of 5 disks do work now and go to standby. Different disks behave different with hdparm...


    Last disk which doesn't go to standby with hdparm -B set to 254 and 255. When using -B 127 it does go to standby, but much faster as set (all in GUI) .
    So would like to experiment with -B (253) and -S.
    But settings for -B in GUI are limited and can't just edit /etc/hdparm.conf, because changes will get lost.


    I recently discovered "omv-salt deploy run fstab" when needed to change something there. Can I use omv-salt to make changes to /etc/hdparm.conf permanent? Or any other way to do this?


    @votdev I know you're very busy developing, hope you can help though!


    Edit:
    Some info here
    Have 2 of these Samsung disks, and setting APM to 255 was solution for that. For the other to WD drives I use 254 (which says APM is not supported with hdparm -B /dev/WD drive, so they will probably work with 255 as well i guess).
    But the one not willing to go to standby with APM set @ 255 and 254 is a SAMSUNG HD753LJ...


    Edit 2:
    For SAMSUNG HD753LJ: when set to -B 255 in GUI and after use command: "hdparm -B /dev/sdf" disk does go to standby in exact time set in GUI...


    Edit 3:
    There is a different behavior between boot/reboot and put system in and out of stand-by regarding disks going to stand-by.
    With boot/reboot all WD disks go to stand-by. When system has been in stand-by and woken up, WD disks don't go to stand-by.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!