Fujitsu Siemens Raid Controller communication problems

  • Hello everyone,
    I have just build a NAS with OMV. I am using a Fujitsu-Siemens D2516 C11 raid controller card in one of the pcie slots and have a raid 5 configured. Now everything seemed to work perfectly fine first. In OMV the raid 5 volume shows up as a single drive and I have successfully created a filesystem on it and even a shared folder. But every few minutes when OMV is trying to read or write to or from the raid volume it throws a communication error message. Clicking the 'Show Details' button just opens a text box that contains 'communication error' and nothing else. When I try to copy a large file to the raid volume it starts out very good, but at one point it just stops dead in its tracks and wont continue until it throws a random error message.
    So I guess there is some sort of problem with OMV not properly recognizing the raid controller. Is there any way I can get this to work or would I need to buy a different raid controller or hba or even just use unraid or some other os?

  • So I guess there is some sort of problem with OMV not properly recognizing the raid controller.

    Nope, not an OMV problem, TBH using a raid controller as a raid controller is not a good idea in Linux, the card needs to be flashed to IT mode HBA (host bus adaptor) so that you can set up your raid using OMV (mdadm software raid) this allows you to monitor each individual drive.
    Using a raid card this way you have no way of monitoring the health/state of each drive attached to the card.


    EDIT: does the card bios allow you to select hba/IT mode, some do some don't.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!