shares not working! device mapping issue?

  • Hi guys -


    OMV5 5.2.6-1


    after updating using GUI Menu (OMV-Extras > update) omv-update zfs stopped working with errors.
    I worked out the following:
    ZFS wants the Proxmox Kernel, (was installed initially) - the Update process updated the "normal" Linux kernel and for some reason put it as default - so ZFS produced errors
    after a bit trial and error where I didn't realise it was the kernel making problems,
    I deleted the ZFS plugin, switched to the proxmox kernel - reboot - reinstall zfs - boom zfs is working, and Pools are imported flawlessly



    The problem is, that all shares stopped working and also I cant delete or add new ones.
    If I try adding a new one, under device the list is empty


    Probably some file where the devices aka zfs pools are listed is deprecated and does not update?
    Any clues how to fix that?

  • hm how do I edit the config.xml without shares? can you make a share of the system drive anyway?


    btw this is the error message (cut off due to maximum characters restricition) when i try to delete a share:


    Code
    Die Konfiguration wurde geändert. Sie müssen die Änderungen bestätigen damit sie wirksam werden.
    HOME-NAS.local
    Seite
    von 1
    Zeige Items 1 - 10 von 10
    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; omv-salt deploy run systemd 2>&1' with exit code '1': debian: ---------- ID: remove_sharedfolder_mount_unit_files Function: module.run Result: True Comment: file.find: ['/etc/systemd/system/sharedfolders-Backup.mount', '/etc/systemd/system/sharedfolders-Download.mount', '/etc/systemd/system/sharedfolders-Filme.mount', '/etc/systemd/system/sharedfolders-Foto.mount', '/etc/systemd/system/sharedfolders-GSD.mount', '/etc/systemd/system/sharedfolders-GSDVR.mount', '/etc/systemd/system/sharedfolders-Serien.mount', '/etc/systemd/system/sharedfolders-Video.mount', '/etc/systemd/system/sharedfolders-docker.mount', '/etc/systemd/system/sharedfolders-dockerapps.mount'] Started: 21:59:52.746377 Duration: 2.904 ms Changes: ---------- file.find: - /etc/systemd/system/sharedfolders-Backup.mount - /etc/systemd/system/sharedfolders-Download.mount - /etc/systemd/system/sharedfolders-Filme.mount - /etc/systemd/system/sharedfolders-Foto.mount - /etc/systemd/system/sharedfolders-GSD.mount - /etc/systemd/system/sharedfolders-GSDVR.mount - /etc/systemd/system/sharedfolders-Serien.mount - /etc/systemd/system/sharedfolders-Video.mount - /etc/systemd/system/sharedfolders-docker.mount - /etc/systemd/system/sharedfolders-dockerapps.mount ---------- ID: configure_sharedfolder_Backup_mount_unit_file Function: file.managed Name: /etc/systemd/system/sharedfolders-Backup.mount Result: True Comment: File /etc/systemd/system/sharedfolders-Backup.mount updated Started: 21:59:52.750673 Duration: 2.471 ms Changes: ---------- diff: New file mode: 0644 ---------- ID: configure_sharedfolder_Foto_mount_unit_file Function: file.managed Name: /etc/systemd/system/sharedfolders-Foto.mount Result: True Comment: File /etc/systemd/system/sharedfolders-Foto.mount updated Started: 21:59:52.753236 Duration: 1.575 ms Changes: ---------- diff: New file mode: 0644 ---------- ID: configure_sharedfolder_Video_mount_unit_file Function: file.managed Name: /etc/systemd/system/sharedfolders-Video.mount Result: True Comment: File /etc/systemd/system/sharedfolders-Video.mount updated Started: 21:59:52.754894 Duration: 1.55 ms Changes: ---------- diff: New file mode: 0644 ---------- ID: configure_sharedfolder_Download_mount_unit_file Function: file.managed Name: /etc/systemd/system/sharedfolders-Download.mount Result: True Comment: File /etc/systemd/system/sharedfolders-Download.mount updated Started: 21:59:52.756527 Duration: 1.539 ms Changes: ---------- diff: ............


    and yes all services using the sahres are turned off ..

  • hm how do I edit the config.xml without shares?

    ?( I thought that you have already some shares which stopped working after the upgrade, as you have written in your post #1?


    I have never done any changes to config.xml in the past because it is the main openmediavault configuration database. So before you make changes to config.xml please make a copy of it to be able to restore it if necessary.

    OMV 3.0.100 (Gray style)

    ASRock Rack C2550D4I C0-stepping - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1) - Fractal Design Node 304 -

    3x WD80EMAZ Snapraid / MergerFS-pool via eSATA - 4-Bay ICYCube MB561U3S-4S with fan-mod

  • Yes I have shares - none of which are working, but I also cannot add any ..


    In your Link the solution seemed to be editing the xml file - I don’t know how to get access to it anyway - I probably will reinstall omv entirely, since it’s the quickest way to get to my data again.


    edit: it would be so easy if there were just a button to delet all shares and go back to the starting configuration (maybe something for a feature request?)



    there is only the hassle with getting the docker containers back into portainer without redoing everything - any ideas how? There on the file vault, not on the system drive ..

  • In your Link the solution seemed to be editing the xml file - I don’t know how to get access to it anyway

    It´s located at /etc/openmediavault/config.xml. See the FAQ: Openmediavault V4 FAQs
    It is not possible to access it via the WebUI. You have to do it by command line interface over SSH or with e.g. WinSCP.

    OMV 3.0.100 (Gray style)

    ASRock Rack C2550D4I C0-stepping - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1) - Fractal Design Node 304 -

    3x WD80EMAZ Snapraid / MergerFS-pool via eSATA - 4-Bay ICYCube MB561U3S-4S with fan-mod

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!