Installation on fresh Debian 9 fails

  • Hello and I hope anyone can help me so I can can use this awesome software again.
    I needed to reinstall my debian server. I used a normal Debian x64 distro.


    I respected everything written here https://openmediavault.readthe…stallation/on_debian.html


    Error message


    Quote

    The following packages have unmet dependencies:
    openmediavault : Depends: monit but it is not going to be installed


    When I try to install monit


    Quote

    The following packages have unmet dependencies:
    monit : Depends: libcrypt1 (>= 1:4.1.0) but it is not going to be installed


    And this continues with other pa ckages too.


    Please help me :(

  • Which version of Debian 9 did you use for installation. I did it several times and didn't face any problems.


    I used this version for basis installation. At the end when you have to choose which packages to install I only ticked "ssh server" and "standard system utilities". You don't need more. Don't install a GUI like Xfce ....


    After the the first login with root (I install the server with a keyboard/mouse and screen attached) I enabled root. After that I reboot the server again.


    And then I connected from another PC/laptop to the terminal of the Debian server and install OMV like this:



    Code
    apt-get update
    apt-get upgrade
    apt-get dist-upgrade
    echo "deb http://packages.openmediavault.org/public arrakis main" > /etc/apt/sources.list.d/openmediavault.list
    apt-get update
    apt-get install openmediavault-keyring postfix
    apt-get update
    apt-get install openmediavault
    omv-initsystem
    reboot

    And voila you can connect to your OMV-server.


    My suggestion is to jump to OMV v5. Therefore install Debian 10 netinst (also packages "ssh server" and "standard system utilities" at the end) and OMV v5 over it. Here in the forum under "Guides" you will find the description to install OMV v5 over Debian 10. My suggestion don't use the script which is posted here in the forum too. I had problems with the installed flash memory plugin which I didn't need. So do it by hand via terminal.

    OMV-Server-HW: MoBo Fujitsu D3417-B2 (Intel-LAN), Intel Xeon E3-1245 v6 Kaby Lake (4x3.70GHz), 16GB-Ram ECC UDIMM, 1x512GB SSD Samsung 850 Pro (sda2 - 30GB system, 4GB swap, sda5/rest - for work), 1x 10TB WD Red Pro, 1x 3TB WD Red (both basic setup) - Digibit R1 Sat-IP-Server with SatIP-Axe-Firmware


    OMV-Server-SW: Debian Buster with Proxmox kernel (always up-to-date), OMV v5 (always latest), omv-extras-plugin (always latests), AutoShutdown-Plugin, Docker with PlexMediaServer, TVHeadend, any many more


    BackupServer: Synology DS1010+ with 4GB Ram, 9TB@SHR (different hdd's), DSM 5.2-5967-2

  • I installed from netinstall like everytime. 4.19.0-6-amd64 #1 SMP Debian 4.19.67-2+deb10u2 (2019-11-11) x86_64


    I did exactly the steps you mentioned and still get the "depends on monit" error. monit is, as said above, installed.


    When I want to install monit it says libcrypt1 is missing. When installing libcrypt1 it says a lot of other things about lib6, libngnx-mod-http-auth-pam and so on.

  • My suggestion don't use the script which is posted here in the forum too. I had problems with the installed flash memory plugin which I didn't need. So do it by hand via terminal.

    This is a bad suggestion. The script does many things that guide doesn't mention and I'm pretty sure I have installed OMV so many times that I know how to install it correctly. I really don't understand how you had problems with the flashmemory plugin but you could just remove it or I could add a flag to not install it. It doesn't hurt to be installed on any system.


    I'm not sure what is causing the monit error because I can't reproduce it but I would use OMV 5.x and the script.

    omv 5.3.9 usul | 64 bit | 5.3 proxmox kernel | omvextrasorg 5.2.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Just checked it again. monit and all the rest is not installed. monit can not be installed either because libcrypt1 isn't installed and so on. All ends with ... (sorry, it's german!)


    All packages above except libcrypt1 and monit are already installed.


    I re-created my sources.list file like the following. It "seems" to work. I will let you know later. It's installing at least - needs to download about 600 MB


    URL: https://debgen.simplylinux.ch/index.php?generate

  • I re-created my sources.list file like the following. It "seems" to work. I will let you know later. It's installing at least - needs to download about 600 MB

    You don't want to use stable. Change those to buster.

    omv 5.3.9 usul | 64 bit | 5.3 proxmox kernel | omvextrasorg 5.2.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I got everything installed now. My PiHole (port 80) and Nextcloud (another port...)are still working (nginx server).
    I changed the omv port to something else than 80 (I already did that before reinstalling my server) and everything worked.


    But now when I open the admin interface I get error 502. What could that be?


    Webserver user: www-data. The folder and files created in /var/www for openmediavault are bind to another user (openmediavault-webgui). When I change it to www-data nothing changes.


    nginx config

    When I just copy my default nginx config and apply it to the omv config file I get a response but not a good one


    Code
    Error #0:
    OMV\Exception: Failed to open file (filename=/var/cache/openmediavault/cache.omv\controlpanel\login_js.json, mode=w+). in /usr/share/php/openmediavault/json/file.inc:78
    Stack trace:
    #0 /usr/share/php/openmediavault/controlpanel/controlpanelabstract.inc(182): OMV\Json\File->open()
    #1 /var/www/openmediavault/index.php(46): OMV\ControlPanel\ControlPanelAbstract->render()
    #2 {main}
  • ut now when I open the admin interface I get error 502. What could that be?

    You changed to php 7.4 manually. That will not work. Please don't manually change things and then have us try to figure out why it is broken.

    omv 5.3.9 usul | 64 bit | 5.3 proxmox kernel | omvextrasorg 5.2.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Why does php7.4 not work? I needed 7.4 for another webservice.

    OMV is a php app coded for the stable php release of the version of Debian it is meant to work on. For OMV 5.x, that is 7.3. If you need 7.4 for something, use docker or a VM.


    should I completely reinstall the server maybe? This time using the omv image (openmediavault_5.0.5-amd64.iso) directly instead of pure debian?

    Yes. Yes.

    omv 5.3.9 usul | 64 bit | 5.3 proxmox kernel | omvextrasorg 5.2.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!