SAS Write Cache not enabling

  • Have OMV 5.3.2 installed as a VM in Proxmox. 4 SAS drives are passed through (with scsiblock=1).


    Running 'sdparm -g WCE /dev/sdb' shows that Write Cache is disabled.


    Code
    WCE 0 [cha: y, def: 1, sav: 0]


    Go into the WebUI and enable Write Cache for the same drive (save and apply), sdparm still shows it disabled.


    So I used 'sdparm -s WCE --save /dev/sdb', then check what sdparm shows and yes it reports that it is enabled. WebUI shows it's disabled.

    Code
    WCE 1 [cha: y, def: 1, sav: 1]


    Should OMV work with SAS drives and Write Cache through the WebUI?

  • No, not at the moment.

    votdev

    Any reason we couldn't just install sdparm on the OMV server and manage outside the OMV gui? Just ignore the hdparm settings?


    OMV is just an app on top of Debian, right? Just wondering if there's anything in the OMV app that would conflict with using another service for HD power management?

  • Any reason we couldn't just install sdparm on the OMV server and manage outside the OMV gui? Just ignore the hdparm settings?

    Yes you could probably do that.


    OMV is just an app on top of Debian, right?

    Yes and it usually completely controls the config files of the services it maintains.

    Just wondering if there's anything in the OMV app that would conflict with using another service for HD power management?

    If you don't do anything in the hard drive power management part of the web interface, it shouldn't conflict. Try it.

    omv 5.6.2 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.5.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!