Error right after login: Invalid IP address

  • Hi


    I've setup a new Raspberry Pi 3+ with OMV 5 and have problems right after login. Not allways, but often Just right after clicking I get this:


    Error #0:

    OMV\HttpErrorException: Invalid IP address. in /usr/share/php/openmediavault/session.inc:185

    Stack trace:

    #0 /usr/share/php/openmediavault/session.inc(207): OMV\Session->validateIpAddress()

    #1 /var/www/openmediavault/index.php(34): OMV\Session->validate()

    #2 {main}


    Raspberry has been set up with newest Raspbian and with the install script as mentioned in the documentation in the download area for single board computers. The only thing I chnaged is that I reenabled ipv6 as this was not working after installation. Following another thread I changed in /etc/sysctl.d/99-openmediavault.conf the


    # Enable/Disable IPv6

    net.ipv6.conf.all.disable_ipv6 = 1

    net.ipv6.conf.default.disable_ipv6 = 1


    to 0. With this change I get correct IPv6 (public and ULA), with correct routing and listed in DNS on the router.


    But it now kicks me out sometimes and I wonder if this is due to the different ip addresses (which shouldn't be a problem). So is there maybe some of the UI pages relying fixed on IPv4 maybe?


    Any help welcome.


    King regards

    S

  • This is what I thought. But why?


    I use Firefox and connect to the pi-kodi by its name. A host query on my maschine gives me three IPs for the pi-kodi: one IPv4, one IPv6 ULA and one IPv6 with public prefix.

    It also happens on a very few pages only. Right on/after the login and when going to System Information -> Performance statistics.

    If I connect to the pi-kodi by IPv4 or IPv6, everything works fine.


    As this behaviour only happens on OMV 5 (i have two pis), never happened before with OMV 4 (where I didn't had IPv6) and does not happen at all on any other system or web-site, I wonder where the problem is.

  • If you are accessing the OMV web interface before rebooting and you used the install script on an RPi, the IP address is most likely going to change because the install script switches network config to systemd-networkd.

    omv 5.5.1 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!