OMV not booting with missing disk

  • First time OMV user. Testing my planned set-up with USB thumb drives before deployment.


    I am using unionfs and SnapRAID.


    I want to test if SnapRAID works so I set up a simple 3 drive array (one parity, 2 with content/data).

    After syncing I "simulate a drive failure" (yank out the thumb drive).


    Under the Disks panel the missing disk is replaced with this: /dev/disk/by-label/[missingdisklabel]

    I can not remove that entry. I tried replacing the disk and wiping it/creating a new FS on it but it didn't work.


    If i reboot the machine, the missing disk is a dependancy of the unionfs volume (and for /dev/disk/by-label/[missingdisklabel]).


    The OS boots into emergency mode, if I press ctr-d it claims it is "starting default target" but just loops back to emergency mode.


    Ultimately I just want to be able to go through the process of setting up an array, losing a disk and recovering it.


    Could somone please advise me?

  • You should add "nofail" to the options of your file system, if a disk is missing the unionfs will just not be mounted, then you can boot normaly and recreate the unionfs with an other disk and rebuild missing data

    https://www.reddit.com/r/OpenM…1/mergerfs_drive_failure/

    Thank you milouz.


    This sounds exactly what I need to do. However, I have been trying to add the nofail option without success.

    All the thumbdrives have the option already in fstab. I can't add it for the union volume.

    When I try to include the option during gui setup of the merge, I get an error when applying the changes.

    I have also tried to add the option to fstab after creating the merge but I can't do that either.


    Any advice?

  • Well I'm a little late to the party, but I found how to deal with this problem. If you try to save any changes to the filesystem section with nofail in the options for unionfs it will error as for some reason debian is ok with it on physical disks but doesn't like it with mergerfs. So to fix it, you remove the nofail option in unionfs and save your filesystem changes, then once it's done put the nofail option back in and save again.


    So basically for unionfs the nofail option must be applied AFTER you've applied any changes to the filesystem configuration.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!