Pihole OMV5 DNS resolution is currently unavailable

  • I have a pihole running on RPi4 and wanted to install a backup instance on my OMV5 NAS. Been trying to get it working for a week now and keep getting this error in logs. I am using macvlan because I have letsencrypt running and cant publish ports 80 and 443 otherwise.

    Searched through the posts and found several possible fixes (adding DNS 127.0.0.1 and 1.1.1.1 in env, kernel issues with bpo3, etc) and nothing seems to fix it.

    Currently running the Debian GNU/Linux, with Linux 5.4.0-0.bpo.4-amd64 kernel.


    Pihole states "healthy" for status in Portainer.

    Also I cannot access the pihole admin page by going to https://192.168.1.75/admin/index.php

    I get an error saying "File not found"


    OMV is at 192.168.1.75:85 to prevent conflicts


    Any help appreciated

  • If Pihole is on its own macvlan there should not be any conflict with the OMV GUI regarding ports, because the macvlan has its own IP address.

    I tired changing the port back to 80 and was unable to get access to the WebGUI. It took me to a LetsEncrypt/NGINX "welcome to our sever" page . Had to go through omv-firstaid to change the port back to 85.


    Still no luck with pihole.

  • Thanks! That worked. Its running successfully now per the log. But I cant access the web GUI. When I got to https://<serverip>/admin/index.php

    Keep seeing "file not found"


    When I navigate to pihole.<domain>.duckdns.org I get 502 error


    maybe I need to change some letsencrypt NGINX settings. Is there any changes I need to make to the subdomain.conf file from the sample?

  • What is the <serverip> that you try to access? You need to connect to the macvlan IP, not the OpenMediaVault Host IP.


    Greetings

    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!

  • mastamind

    Added the Label OMV 5.x
  • mastamind

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!