Cannot login to OMV 5.5.6 via Web GUI

  • Hi folks,


    I've been reading up pretty much every single post on this since this issue started up yesterday, and none of them could solve it!


    So far I have:

    - checked that my root directory has plenty of spave (df -h says it's only 28% full)

    - reinstalled omv (apt-get install --reinstall openmediavault)

    - created a limited user that can login

    - reset the admin password

    - reset the failed login counter

    - rebooted a few times

    - removed and recreated the /php/sessions directory and restarted nginx


    It seems that nothing works in my case. I've got a raspberry pi 4 (software last updated yesterday). It was just after the apt-get upgrade yesterday that this issue began.


    Can anyone help please?

  • Hi,

    Very basic verification, as it happened to me several times: clear your browser cache or try a browser you never used before with omv, to see if it fixes the issue.

    OMV5 64bits - Intel i5-7400

    4 * 2TB Hdd Raid 5 + 1 SSD 128Go

  • May you please describe what does exactly happen when you say login fails?

    Do you access login page? Does login fail? ...

    Can you also try to clear your browser cache and retry?

    OMV5 64bits - Intel i5-7400

    4 * 2TB Hdd Raid 5 + 1 SSD 128Go

  • Seems like openmediavault 5.5.5 has not been installed correctly. Execute the following commands to fix that:

    Code
    # groupadd --system openmediavault-admin
    # usermod -a -G openmediavault-admin admin
  • Whenever I try and login I get to the correct screen and ut in "admin" along with the password I've just set. When I then try to sign in I get:


    Error #0:
    OMV\HttpErrorException: Incorrect username or password. in /var/www/openmediavault/rpc/session.inc:151
    Stack trace:
    #0 [internal function]: OMVRpcServiceSession->login(Array, Array)
    #1 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
    #2 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('login', Array, Array)
    #3 /usr/share/php/openmediavault/rpc/proxy/json.inc(97): OMV\Rpc\Rpc::call('Session', 'login', Array, Array, 3)
    #4 /var/www/openmediavault/rpc.php(45): OMV\Rpc\Proxy\Json->handle()
    #5 {main}



    I've tred clearing the browser cache and still get this error. As I mentioned in the original post, I created a test user that has no trouble at all logging in (but can't really do anything once logged in).

  • QVos

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!