php in Nginx in Docker Container on OMV5 can't ftp_put to remote server

  • Problem with linux php ftp nginx portainer docker openmediavault problem.


    With some awesome assistance and guidance by Morlan, I have managed to get Nginx installed and can access the files.


    Next problem is uploading files using php ftp_put from the Nginx based php scripts, to a remote ftp web server.


    Was running OMV4 on RPi3B+ with Nginx as a plugin. Worked 100%.


    Upgraded to RPi4 4Gb and OMV5.


    OMV5 does not have plugin for Nginx, so has to be in a Container in Docker.


    So Installed Docker, Portainer, and created a Stack in Portainer for Nginx.


    In the stack script, I set the Volume to my existing Shared Folder, and I can map network drive to my PC and view & edit these files from my PC. All good so far.


    Started testing php script, and had to make a few small path changes, then everything worked 100%, except for an ftp_put command.


    The ftp connect and Login both work, but the ftp_put simply creates a zero sized file on the destination online ftp server, and after about a minute, then pc browser says : " 504 Gateway Time-out ".


    Found an error log that contains :

    2020/10/21 18:27:46 [error] 333#333: *1 upstream timed out (110: Operation timed out) while reading response header from upstream, client: 192.168.1.91, server: _, request: "GET /EXDdata/testupload.php HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "192.168.1.136"


    I know this script worked perfectly when on the RPi3B+ on OMV4 with Nginx as a plugin, so I assume the problem is related to the new Pi, Docker, Portainer Container settings, or some config on Nginx.


    Anyone able to diagnose this ?

  • DaveOB

    Added the Label OMV 5.x
  • DaveOB

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!