[Solved] HDDs not spinning down

  • TL;DR version: btrace suggests the culprit is a "[pool]" accessing the disk every 600 seconds. What is it and how do I stop it?

    Longer version:

    I've been using OMV for a while and I had this working before, but at some point it stopped working (probably after some upgrade or installing some software).

    I have 2 WD Red NAS HDDs in RAID1 (using mdadm), that are known for having some issues regarding spin down, so I installed hd-idle as a workaround (as suggested in an older thread here) and I managed to get it to work for while... but now it doesn't work unless I put a very low idle time.

    I've increased the smart check interval on OMV web interface to a high number. It currently is 86400 and power mode is set to Standby.

    I've set hd-idle to 1800 seconds, but the disks never spindown... If I change that time to very short time (for example 180 seconds) the disk will spin down, but not with 1800.

    I've run btrace and there's a "pool" accessing the disk about every 600 seconds. Example:

    8,0 1 55 4200.006161055 3626119 D N 0 [pool]

    8,0 1 56 4200.006433144 0 C N [0]

    8,0 1 57 4200.007231231 3626119 D R 512 [pool]

    8,0 1 58 4200.007689361 0 C R [0]


    (there's a few more repeated lines each time and it will repeat every 600 seconds)

    This seems to be the culprit...

    If I put for example 180 on the idle time for hd-idle the discs will spin down and will remain like that.

    [pool] entries still shows up in btrace (now just once every 600 sec) but it doesn't "wake up" the disks.

    "ps aux|grep pool" reveals only this:

    www-data 788 0.0 0.0 204488 6088 ? S out13 0:00 php-fpm: pool www

    www-data 799 0.0 0.0 204488 6104 ? S out13 0:00 php-fpm: pool www

    Is this the pool in btrace? How do I stop it from preventing the disks to spin down?

    Any insight is most welcome! Thanks.

  • bgravato

    Changed the title of the thread from “HDDs not spinning down” to “[Solved] HDDs not spinning down”.
  • After a long time banging my head against the walls (metaphorically) trying to solve this I finally found the culprit with the help from fatrace util (it's in Debian repos), along with btrace.

    The culprit was udisks2. After stopping udisksd the disks spun down without hiccups after the specified time in hd-idle.

    Kudos to the reddit user that suggested using fatrace for debugging.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!