User cannot view files (fresh install)

  • Good Day everyone.

    I ran OMV4 for several years with no issues on my Odriod HC2, but following a drive problem, decided to do a fresh install of OMV5 on my Odroid HC2.

    Got OMV5 running (by using the OMV5 script in armbian-config).

    Mounted my disk, added the shares in both Access Rights Management & SMB sections.

    My primary user can view the shares with no problems. Read/write access is no problem.

    My secondary user (created through the OMV5 interface) receives a permission error each time that login is used to access the shares.

    I have added Read Only access to the user's group (kodi) through the User Rights Management section. However the user in this group is unable to view the shares (just keep being asked to re-enter the username / password).

    It is as if the username / password combo is wrong. However it is really simple (4 letters each) so I'm sure I am typing it in correctly. And my primary username & password are longer and log in fine to the shares.

    Has anyone got any clues as to what could be wrong, or how I could go about getting my secondary user read only access to these shares? I appear to be baffled by something very simple!


  • The files were already on the hard drive, in an ext4 partition, prior to the drive being inserted into the HC2 for OMV5.

    I have tried chmod -R 777 on the folders. I can see through ssh that the command has worked on the folders. However, my users are still unable to access the shares.

    When they connect to smb://omv.local, there is a password request. The Username & Password combo appears to work as a list of shares is then displayed. However, none of the shares can actually be accessed by users.

    Been working on this for about a week and getting nowhere.

    Anyone got an idea of what is going wrong?

    Aside from removing all files from the drive, then copying them over the network all over again (9TB in use, so a very time-consuming proposition), I really don't know what else to try.

    Hopefully someone out there does!


Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!