WOL (wake-on-lan) with suspend, hibernate and shutdown issues problems OMV5.x & Debian 10.7 "Buster"

  • Hello forum!


    Although I am a complete n00b when it comes to Linux and OMV, I successfully installed OMV 5.x on (top) of my Debian 10.7 installation with some random hardware & a Atlantic AQC-107 10GBE NIC.


    I would like to thank you very much for all the excellent guidance and help I have been able to find here and on YT etc. from dedicated OMV users (!)


    But one thing makes my life really hard, namely the configuration of any/some energy saving functions and here specifically putting OMV into a form of hibernate and waking it up again with wake-on-lan (WOL).


    The whole Autoshutdown via Plugin is not working, rep. is doing nothing for me and somehow interferes or dependent on the configuration of the Debian kernel, the ACPI settings in the BIOS and in Debian-OS, the nic & network manager settings, settings in countless .conf files, services, boot options etc. aso.


    What I am trying to say is: Unfortunately, simply checking the "Auto shutdown" checkbox did work for me and it looks to me, that they're many other users who are not able to configure a satisfying energy saving setup...?!


    It took me more then a week to figure out how to bring my NAS-PC into hibernate from the cmd-line, but still not within / out of OMV.


    Now I am searching for a way to "integrate' the below solution into my OMV installation, but have no clue where to start...

    Goal is to hibernate when no one is streaming or doing a backup anything to the NAS.


    This is what I like to share with you...so here's what I did:


    Thanks for reading all this & sorry for my poor English.

    SB

  • KM0201

    Approved the thread.
  • Hello everyone,

    I am glad to communicate a solution for the problem, that my OMV-custom NAS didnt go into a suspend or hibernate status, when not used AND couldnt get up running on WOL.


    Solution:

    I realized the reboot is the result of an not working wake up, beacause of an incomplete hibernation: the image of the hibernation status was not written, so without the last known status, there's no "wake up" possible, just a reboot with "last known good" settings!


    Goal: force the a image-write to ram and to hard disk, maybe swap-partition on hibernate ...

    and force a load of the image on wake up.


    ## show disks to potentially write the hibernate image too ##


    OK, my swap-partition is sda6 and here I can see the UUID which I need for the next step.


    The GRUB setting can be edited quite simply with the "GRUB Customizer", and/or set. I did it in the GUI via a VNC session, Not the best tool, but it works...

    Code
    apt-get install grub-customizer


    I added the "nomodeset"-cmd to grub-config with the UUID of the swap-partition:


    ## after editing, the actual writing in in to GRUB ##

    Code
    root@NAS:~# update-grub


    ## written in the /boot/grub/grub.cfg after that ##

    ## cat /boot/grub/grub.cfg ##

    Code
    GRUB_CMDLINE_LINUX
    acpi_osi=Linux nomodeset resume=UUID=377438db-9374-40a5-8730-0f5827a131ec


    ## or open the grub.cfg with an editor ##

    Code
    [I]...snip[/I]
    echo    'Linux 4.19.0-13-amd64 loading ...'
    linux    /boot/vmlinuz-4.19.0-13-amd64 root=UUID=1748b395-819b-4356-b2ad-0d2b697199a8 ro acpi_osi=Linux [B]nomodeset resume=UUID=377438db-9374-40a5-8730-0f5827a131ec[/B]
    echo    'Initiale Ramdisk loading...'
    
    
    [I]...snip[/I]


    ## check: is it a actual setting now ##




    ## After editing, now force hibernation via CMD ##

    Code
    root@NAS:~# systemctl hibernate


    Please see attached pictures, I couldn't found the logs to copy from, so I took screenshots ;-D

    System closes programs & some services, writes the image to ram and then to disk and then goes into hibernate.

    On start the same thing vice versa...

    You'll find you last cmd in the shell, open folders & files in GUI resp. VNC aso.!!!


    So, this problem is solved (for me) and I it can be set to SOLVED.

    I hope this will help someone else

    SB

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!