/dev/md0 missing

  • Hey guys,


    I found out a connector of one of my drives broke and managed to fix it. however after booting the system I can't access the filesystem.

    I ran some of the recommended commands to find out what is going, but can't seem to find a way to fix it. Is it possible to get back my raid without losing my data?


    Code
    cat /proc/mdstat
    Personalities : [raid6] [raid5] [raid4]
    unused devices: <none>


    Code
    fdisk -l | grep "Disk "
    The primary GPT table is corrupt, but the backup appears OK, so that will be used.
    Disk /dev/sda: 1.8 TiB, 2000398934016 bytes, 3907029168 sectors
    Disk identifier: CA6C511F-5E6C-4595-A557-638307F0BC21
    Disk /dev/sdc: 1.8 TiB, 2000398934016 bytes, 3907029168 sectors
    Disk /dev/sdb: 1.8 TiB, 2000398934016 bytes, 3907029168 sectors
    Disk /dev/sdd: 74.5 GiB, 80026361856 bytes, 156301488 sectors
    Disk identifier: 0x9d60d579
    Code
    cat /etc/mdadm/mdadm.confcat
    DEVICE partitions # auto-create devices with Debian standard permissions
    CREATE owner=root group=disk mode=0660 auto=yes
    # automatically tag new arrays as belonging to the local system
    HOMEHOST <system>
    # definitions of existing MD arrays
    ARRAY /dev/md0 metadata=1.2 name=Vault101:VaultRaid UUID=97b30461:3674ee66:11375fb3:264af412
    Code
    mdadm --detail --scan --verbose

    last command returns nothing


    Thank you in advance for any help

  • blkid returned:

    Code
    /dev/sda: UUID="97b30461-3674-ee66-1137-5fb3264af412" UUID_SUB="01a4b42e-d65a-8044-d29d-a247d66e5c75" LABEL="Vault101:VaultRaid" TYPE="linux_raid_member"
    /dev/sdc: UUID="97b30461-3674-ee66-1137-5fb3264af412" UUID_SUB="e1d9785c-427c-73f2-0260-ba6a0e5004d7" LABEL="Vault101:VaultRaid" TYPE="linux_raid_member"
    /dev/sdb: UUID="97b30461-3674-ee66-1137-5fb3264af412" UUID_SUB="b2831ab5-c249-744a-d659-17d0eccd0a85" LABEL="Vault101:VaultRaid" TYPE="linux_raid_member"
    /dev/sdd1: UUID="a418ec4f-bfe9-4452-870f-d8044a074dd2" TYPE="ext4" PARTUUID="9d60d579-01"
    /dev/sdd5: UUID="6fcc5e37-7ac9-4991-9391-5ce2bb9e5594" TYPE="swap" PARTUUID="9d60d579-05"
  • Hey geaves


    Thanks for your time! I ran the command you suggested, and after the output suggested adding --force it worked!

    I've got my raid working with sda and sdb! is there any way I could add the third drive back in?

  • Sorry the link is timing out, you can copy and paste here using </> on the menu


    Edit: Wait a few hours and it works!! drive appears to be OK no errors reported


    Try mdadm --manage /dev/md0 --add /dev/sdc

    Raid is not a backup! Would you go skydiving without a parachute?

    Edited once, last by geaves ().

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!