OMV on ASROCK H97M-ITX/AC with LAN Atheros AR8171, the old WOL Problem still alive?

  • Hello,


    Is there any solution to the AR8171 WOL problem in 2021? I use OMV Release: 5.6.5-1 with kernel 5.10.0-0.bpo.5-amd64 and everything works fine, except for WOL.

    WOL is activated in the OMV control panel (and Bios :-)) but the entries "Supports Wake-on" and "Wake-on" are missing. The same old story with the AR8171.


    Interface information enp2s0:

    =============================

    Settings for enp2s0:

    Supported ports: [ TP ]

    Supported link modes: 10baseT/Half 10baseT/Full

    100baseT/Half 100baseT/Full

    1000baseT/Full

    Supported pause frame use: Symmetric Receive-only

    Supports auto-negotiation: Yes

    Supported FEC modes: Not reported

    Advertised link modes: 10baseT/Half 10baseT/Full

    100baseT/Half 100baseT/Full

    1000baseT/Full

    Advertised pause frame use: Symmetric

    Advertised auto-negotiation: Yes

    Advertised FEC modes: Not reported

    Speed: 1000Mb/s

    Duplex: Full

    Port: Twisted Pair

    PHYAD: 0

    Transceiver: internal

    Auto-negotiation: on

    MDI-X: Unknown

    Current message level: 0x000060e4 (24804)

    link ifup rx_err tx_err hw wol

    Link detected: yes

    --------------------------------------------------------------------------------

    Driver information enp2s0:

    ==========================

    driver: alx

    version: 5.10.0-0.bpo.5-amd64

    firmware-version:

    expansion-rom-version:

    bus-info: 0000:02:00.0

    supports-statistics: yes

    supports-test: no

    supports-eeprom-access: no

    supports-register-dump: no

    supports-priv-flags: no




    Code

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!