ssh.service failed after reboot, cannot restart (Resolved)

  • After rebooting the server, the SSH failed to start up. Which blows because that's the only way I know how to execute commands (via Putty). When I plug in a monitor/keyboard, the monitor just says "No signal". If I reboot the server, I just get to select which version of debian I boot (currently 5.10.0.bpo.5-amd64), then the screen displays some MCE errors and then goes blank. The server runs fine, I can access through the webUI, Jellyfin runs, etc, but I can't restart SSH.

    The comments that OMV gives me say

    "Job for ssh.service failed because the control process exited with error code.

    See "systemctl status ssh.service" and "journalctl -xe" for details."

    I have no idea how to execute those commands because I don't have access to a command line. Any help would be appreciated as I'm not sure where to go from here.

    Here is the full text of the error readout OMV gave me

    Here's a picture of the MCE errors at startup

  • crashtest

    Approved the thread.
  • Strange. Try rebooting the server (with the monitor and keyboard attached), but select an older kernel this time. If you have several kernels, try each one from newest to oldest. See if that helps?

    Edit: You may be able to execute commands with a little trick: create a scheduled task in the GUI, put your desired command in as the job to run, then run it manually. It would be a pain in the rear end, but it might work to get SSH going again.

  • FIXED!

    Here's what happened. I used cubemin's idea of running scripts through the task scheduler. First I ran "sudo systemctl start ssh.service" and it kicked back the same error. So I then ran "systemctl status ssh.service". It was telling me that SSH couldn't bind to port 22, that something was already using it. I looked up other port numbers I can use and selected a different one and voila! Now SSH works. Putty connects. Life is good.

    Afterwards I looked up a port listening command
    "sudo lsof -i:22" and it told me that rsync was using Port 22. I have no idea why rsync was conflicting with SSH, since I thought it was the same command. But whatever. It works now.

    (I don't know why the font changed mid post. Sorry about that)

  • HubbleWho

    Changed the title of the thread from “ssh.service failed after reboot, cannot restart” to “ssh.service failed after reboot, cannot restart (Resolved)”.
  • HubbleWho

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!