WebGUI refusing to connect after installing and configuring Nextcloud

  • Hello,

    I recently began venturing into the world of servers a few months ago and built my own server a few weeks ago with my install actually managing to stick just yesterday. I was working my way through the various videos I needed to install what I wished from dbtech on youtube. Specifically, once I finished following along with this video

    External Content www.youtube.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.
    my omv web GUI began to refuse to connect. The final steps of this video were to go through various files and enable larger file transfers to the next cloud server. I am unsure this broke my web GUI but it is the last item I changed before it began refusing my connections.

    I have done the following during my install/configuring steps of my server: I have forwarded ports 80, 81, 443, and 499 to my servers IP, the server has a static IP via the router, duckdns is working and allows me to connect to my nextcloud server remotely or locally. Changed the omv webGUI to use port 81

    The troubleshooting steps I have taken are as follows: Attempted to run omv-firstaid and received this error

    Traceback (most recent call last):

    File "/usr/sbin/omv-firstaid", line 92, in <module>


    File "/usr/sbin/omv-firstaid", line 57, in main

    modules = load_modules()

    File "/usr/sbin/omv-firstaid", line 44, in load_modules

    mod = __import__(modname)

    File "/usr/share/openmediavault/firstaid/modules.d/61aptclean.py", line 22, in <module>

    import openmediavault.subprocess

    ModuleNotFoundError: No module named 'openmediavault.subprocess'

    The error I receive when attempting to connect to my server locally by typing myserver.local:81 in the address bar is: ERR_CONNECTION_REFUSED\

    This exact webaddress was working when I was configuring the server prior to finishing following the walkthrough video I linked.

    I would love any help I could get! I am ready to provide clarification and any results of any commands in my ssh terminal. I am able to connect via ssh and I am able to get into my nextcloud server. I would hate to do a fresh install as I had moved all my files from google drive over to my nextcloud server before noticing that my omv webGUI was not working. I do have all the data for my next cloud server on a separate drive than OMV. So if there is a need to do a fresh install is there a way to unmount and remount the drive with the data to omv and not lose any progress? Thanks for your help in advance!

  • The final steps of this video were to go through various files and enable larger file transfers to the next cloud server.

    You're right, this is where it went "Kaput"

    This guide says to search for all "nginx.conf" and edit them. WRONG.


    Upload Size Fix

    Next we’ll fix a maximum file size upload issue.

    In your Putty application, type this in:

    find / -name "nginx.conf"

    The screen will return several lines and will look something like this:

    You’ll need to edit each of those nginx.conf files. In those files you’ll make sure that you add the following:

    Again, WRONG.

    And even WRONGER, is by NOT saying to make a backup copy first.

    You're installing on docker, you MUST NOT touch files in your system.

    Editing the "/etc/nginx/nginx.conf" (which belongs to the root system), won't do anything to the Nextcloud on docker, but will mess with OMV (as it did) or with any other website (if you have) that runs on the system with connection to NGINX.

    Try to undo the steps you did to that file and see if it solves it (you'll need to do it via terminal).

  • I'm usually quite the nerd for using proper English, but if ever I would approve the use of the word "Wronger", this would be the case. :)

    Thank you for the "approval", but the word really looked adjusted to the situation, :D

  • This worked perfectly!!! Thank you so much. I was confused as to why I was in need of editing root-level file systems when the video was prompting it. I see now that my itches were correct. Thanks again!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!