Posts by KM0201

    I have tried with the code that you have published and the result I get is the same, except that before locally if I could access with the url and now not. The first screenshot is the result of trying to enter with the url from local, the second is the open ports in the router and the third is the attempt to access from outside my local network. I also publish the swag log.


    Edit

    I also add the code of my docker compose


    I'm not seeing the problem, you successfully got a cert.

    He's got several weird settings in that stack. Even looking at swag's example duckdns compose, his makes no sense... It looks like he's combined an http setup with duckdns and.. who knows what else. It will never work if he doesn't set that up properly.


    Since I hadn't used it in a while, I just tested that compose I gave you and had it up in like 45sec...




    Notice how my domain is secured


    Yes, the OMV port 80 I changed it to another port, so in principle there should be no conflict with it, in fact, if I access with my public ip to port 80, it appears to me that swag is working correctly as seen in this screenshot.


    My swag code

    If you're using duckdns, your vallidation is wrong. I thas to be set to duckdns. Also, duckdns and swag REQUIRES subdomains be set to wildcard. I've not used duckdns and swag in a while, but below is always the compose I give to new users trying to get it working. Also, I've found duckdns sometimes takes a LONG time to propagate, and swag.. i think the default is 10sec. If duckdns does not propagate in that time, you will fail to get a cert. This is why I manually set the PROPAGATION on duckdns to 30sec (that's never let me down). I'm fairly certain this is in the swag documentation.


    Edit: Also, your swag install is NOT working correctly, that page will be secured if it is (I assume non seguro means not secure... you should have a padlock there indicating it is a secure site)


    Edit 2: Man you have several weird settings/issues, why are you mapping your config folder inside /var/docker? Are you sure you have permissions set properly on that folder?



    I have tried to change npm by swag and nothing, locally with the url (eg jellyfin.mysubdomain.duckdns.org) if you let me access, but externally there is no way.

    I tried before switching to swag this port forwarding and nothing, it keeps loading and at the end it gives connection error.

    I could be wrong, but I'm almost 100% sure the documentation for npm, says that 80 and 443 is REQUIRED (you can't port forward them to another internal port). In this case, you'll have to put OMV on a different port, since it also uses port 80... That's what I ended up doing.


    I don't mysql for npm.. to me that seems to unecessarily complicate the matter...

    Easy peasy


    To configure a wildcard domain in Nginx Proxy Manager and duckdns you just have to do this:

    • Configure a domain in duckdns and point to the router's public IP. Check this on https://www.whatsmydns.net/
    • Open ports 443 and 80 of the router and direct them to the IP of the server on the local network.
    • In the NPM GUI go to the SSL Certificates tab and click the Add SSL Certificate button. Configure it as in the following image, specifying the duckdns token:



    If it is with another provider, it is necessary to select the provider in the DNS Challenge.

    When I do it that way i get a cert error when it tries to pull

    I recently configured my NAS server with OpenMediaVault and docker for some services like Nextcloud, Jellyfin, etc. I want to access them from outside my local network, so I am using Nginx Proxy Manager and my duckdns subdomain. The problem is that I have on the router open ports 80 and 443, but I can't access any of the services I have installed. I have npm configured with a wildcard for my duckdns subdomain ex: *.mydomain.duckdns.org. > nextcloud.mydomain.duckdns.org. Also I have configured to update my public ip with the tutorial of the duckdns website, and if I try to enter with my public ip and the port of the service (having it open) if I access without problems. Am I missing something or I have not configured correctly?

    I know they say it works, but personally, I've had issues with NPM and wildcards.... (was never an issue with swag)


    Usually, I set it to pull a cert for (example)

    nextcloud.my-domain.xyz


    Then when I go to add a new subdomain (say calibre)... I set it up, then when it comes time to pull a cert, my "nextcloud" cert is in the list, and i just choose it, this then causes my nextcloud and calibre setups to use the same cert.


    YMMV


    Edit: I should note, I don't think I've ever tested that with duckdns, but it works through my Namecheap domains that I purchased just fine. I'll have to test duckdns at some point.

    i know omv isnt an os lmao, i meant i didnt flash the preconfigured installer thingy os from the omv site. i just flashed debian lite, set some stuff up and then installed omv with the script. also, are there any paticular reasons omv6 wont work on debian 12?

    well if you know OMV isn't an OS, why are you rambling about which image you flashed? It doesn't matter whether it's an OMV image or a Debian image and you use the script to install OMV on top of Debian.. You end up at exactly the same place...


    Yes the reasons are


    OMV 6 was designed to work on Debian 11.


    OMV 7 was designed to work on Debian 12.


    but you're welcome to give it a try if you like. Please post your results.

    i installed omv after debian, i didnt flash an omv os image.

    plus omv6 would likely work fine on debian 12 anyway. but also, if omv7 isnt released, how come im running it from the default raspi installation script?

    Technically OMV is not an OS, OMV is software that runs on top of an OS. It provides a GUI front on some services, makes things easier to install/configure via that GUI, etc. The underlying version of Debian, is the actual OS.


    No, OMV 6 will not work on Debian 12. If you read the tags on your thread, OMV 7 is tagged "RC1".. That's Release Candidate 1. While it is basically stable, it is technically not the stable release yet. OMV 6 is the current stable release. However, as mentioned.. OMV 7 is bound to convert to stable any time now (I've used it about 3mo w/o issue).. Debian 11 (that OMV 6 is based on) goes EOL in July, so I'd expect OMV 7 sooner rather than later.

    im not using debian 11, and tbh as long as my stuff works properly and security is recent im going to be honest: i dont care that much, i would much rather a functioning nas slightly less secure than a half-working more secure one.

    Uh.. Debian 11=OMV 6. OMV 6 will typically go EOL when the next version of OMV is released, but the Debian release it's based on usually hangs around a little longer.


    As for your logic on security, I'll just say I strongly disagree.

    so jus to confirm, there is no way for me to get smart statuses working again unless i update the database?

    I mean... If he's going to disable it because he knows it causes problems, why on earth would he tell people how to circumvent it?


    I've used software that Votdev was lead on for a long time (going back to FreeNAS, and using OMV since it's the .2 beta).. I've generally found he doesn't make decisions without some fairly sound logic, even if may not 100% make sense to me.


    To me, this pretty well sums it up.. he considers this more of a hardware issue than a software issue... thus why he won't address it.


    Code
    The GitHub post explains why it does not make sense to try to fix that in the OMV code. There is too much hardware out there to do the job in OMV.
    
    If your hardware is not working, contact the hardware manufacturer to contribute to smartmontools or buy hardware that is supported.