Direct attach Workstation Bridge

  • Hi all,


    I recently acquired some gear to go 10GB between my PC and my OMV box. Currently I would like to set up a bridged configuration which would allow my OMV box to effectively act as a network switch connecting its onboard 1Gb uplink to the rest of my home network, with the 10Gb port on my Intel X540-T2. At the moment I am having difficulty getting my client PC to connect to the wider network, I've tried static IP and DHCP on the client side however I don't seem to be able to get it to communicate with the wider network.


    uU81lVK.png


    The bridge device includes both the adapter connected to the wider network and the network adapter attached to my PC. For reference, my PC is running Windows 10 and the network card has been able to negotiate a 10G connection to the server, just no actual network connectivity.


    Any help would be much appreciated 8)

  • TechGuy

    Changed the title of the thread from “Direct attach Workstation Bride” to “Direct attach Workstation Bridge”.
  • Doing some more testing with a Debian live image, I have been able to achieve a stable and performant (9.5 Gb) bridge using the /etc/network/interfaces config style in Debian 10. Both connectivity to my server and to the broader network works as expected with a static IP. At this point, I believe this indicates that my network is not blocking bridging interfaces, rather there is an issue with the software stack used for networking in OMV. I believe there were some issues with bridging identified in systemd-networkd version 421 which were fixed in 422. I'm going to try configuring a bridge in my live image environment with systemd to isolate whether the issue lies in the renderer (systemd-networkd) or with the configuration through netplan.


    I also was able to get the bridge to work for a short time 3-5 minutes after boot, however after this point, I get the same issue on my client ('No internet' error in Windows settings).

  • Further testing shows that the netplan.io configuration path and the systemd-networkd bridges work as expected in a clean Debian install. Depending on the versions of these programs used in Debian Buster vs OMV 5.x (which are likely the same given OMV 5.x is based on Debian Buster), if they are the same, then this indicates to me that a piece of software in the OMV network stack is interfering with my bridge configuration. I may attempt a fresh install of OMV on a separate drive and see if that makes a difference (thinking maybe some artifacts of older configs are causing issues).

  • I've identified the issue with my install. I use docker to host some services on my install, however when docker is installed it forces the use of legacy iptables instead of nftables. I believe this may be the issue I'm facing with the bridge, as it worked perfectly before docker was installed on a fresh OMV install. As soon as Docker was installed, it broke the bridge. I may need to alter how the docker bridge interacts with the other network interfaces in the system to get it to stop interfering with my bridge.

  • Installing Docker from omv-extras does not automatically enable legacy iptables. You have to do that manually from the menu.

    omv 6.0.8-1 Shaitan | 64 bit | 5.15 proxmox kernel | omvextrasorg 6.0.5 | kvm plugin 6.0.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Installing Docker from omv-extras does not automatically enable legacy iptables. You have to do that manually from the menu.

    Appreciate your response, definitely helped me troubleshoot!


    In the end (if anyone stumbles upon this in future), it was clear that Docker's network design was interfering in some way with the OMV bridge configuration. While I'm sure there would be a way to configure them so that they work together, for me the simplest solution was to run the software in my containers within the OMV Debian environment (bare metal). This allowed me to uninstall docker and use the physical network adapter bridge (as configured in OMV) with no issues.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!