NVIDIA-SMI couldn't find libnvidia-ml.so library in your system. Please make sure that the NVIDIA Display Driver is properly installed and present in your system.

  • I just attempted to upgrade the nvidia driver on my system since PLEX no longer liked the older version I had installed.

    I followed the guide here on the forums : [HowTo] Nvidia hardware transcoding on OMV 5 in a Plex docker container

    But now when I try to run nvidia-smi I get the following error.

    Code
    NVIDIA-SMI couldn't find libnvidia-ml.so library in your system. Please make sure that the NVIDIA Display Driver is properly installed and present in your system.

    So since I cannot get the nvidia driver to work on the host, then of course I cannot get the docker to use the runtime.


    I can see the file located at /usr/lib/x86_64-linux-gnu/nvidia/current/libnvidia-ml.so and have tried to add that directory to the PATH but it did not resolve the issue.


    Any help would be greatly appreciated.

  • I would recommend you try to install the diver again by following the link [HowTo] Nvidia hardware transcoding on OMV 5 in a Plex docker container to the letter.

    Myself ran into problems before, because I did not have all those in etc/apt/sources.list

    deb http://deb.debian.org/debian/ buster main contrib non-free

    deb http://deb.debian.org/debian/ buster-updates main contrib non-free

    deb http://deb.debian.org/debian-security buster/updates main contrib non-free


    and by the way to run nvidia-smi the command is

    Code
    watch -d -n 0.5 nvidia-smi
  • I have tried this guide at least 5 times, with the same results.

    The watch in front of the nvidia-smi commands just basically have that command refresh itself.

    I am still getting the same error

    Code
    NVIDIA-SMI couldn't find libnvidia-ml.so library in your system. Please make sure that the NVIDIA Display Driver is properly installed and present in your system.
  • Double check your etc/nvidia-container-runtime/config.toml for typo

    Also some people may have found a solution by changing @/sbin/ldconfig" to "/sbin/ldconfig" in /etc/nvidia-container-runtime/config.toml


    https://github.com/NVIDIA/nvidia-docker/issues/1163


    As for me (probably different issue but related) I remember some time ago I got an issue with container messing up my Nvidia and I had to do it again (nvidia diver Install )on a new OMV fresh install so from now on I got a cloneZilla backup of my 3 partitions Boot, OMV ,and dockers something to keep in mind.

  • Thanks for the tip, I did check that, and still same issue.

    It should be noted that I am getting this error on the host and not in the docker. Since it isn't working/installed properly on the host, then I definitely know it will not work in a docker container.

    Any other advice?

  • When you try to install [HowTo] Nvidia hardware transcoding on OMV 5 in a Plex docker container If you get any errors, you have to start from the beginning again, and as I said before you may need to start with a fresh OMV install and I forgot make sure your bios use the nvidia card and not the buit-in gpu.

    I did not see any errors. The bios settings are good. The nvidia driver was working previously before installing updates, which is what started this issue.

    Thanks for the suggestions, but I would prefer not to rebuild my omv server from scratch.

  • I was finally able to resolve my issue. I purged the nvidia packages again, but this time before starting over, I removed the libnvidia-ml.so file located at /usr/lib/x86_64-linux-gnu/ and I also manually deleted the /usr/lib/x86_64-linux-gnu/nvidia directory.


    Then everything seems to go great and is now working fine.


    Thanks for taking the time to try and help, and for anyone having this issue, after performing the normal steps mentioned above, this is another option.


    Thanks again.

  • ADXGlock

    Added the Label resolved
  • I am glad you got it working again

    its interesting to learn that

    Code
    apt-get purge *nvidia*
    apt autoremove
    apt autoclean

    does not remove everything.

    Your latest post will help, if somebody or myself run into this issue.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!