OMV - RPi4 - High loads after update // Please advise

  • Hello all,


    I am running OMV 5 5.6.13.-1 on a Raspberry pi 4 using the Argon One M.2 case.


    The server has been working well for quite some time. I had around 30+ day uptime and

    I decied to do some updates and reset the server.


    After the reboot, I running into a strange issue where my CPU load average keeps going up and constantly. It went to around 11 at one point


    I unplugged my NAS storage and the issue still persists. I ran htop as well and can't find anything too out of the ordinary.


    Update: Using top

    I did notice php-fpm: pool openmediavault-webgui will use 45% for a few moments drop then repeat again


    I noticed as well rebooting OMV will cause the Pi to crash - I will have to manually remove and put the power back in


    Pictures

    Load average


    Htop


    Any ideas what the issue could be?


    Thank you,

    Dan

  • Is the RPi booting from sd or m2? I would look at the i/o wait in top as well. If the OS media is having issues and you have docker on it, I could see the load being high.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Is the RPi booting from sd or m2? I would look at the i/o wait in top as well. If the OS media is having issues and you have docker on it, I could see the load being high.

    Yes the Rpi is being booted from M2 and I have docker installed. I looked at the i/o wait and did go to 0.1 then back to 0 then 0.1 again later. The issue is strange - the load just slowly keeps going up and up and at one point I lost communication with the web server.


    I uninstalled docker too to see maybe it was docker acting but the load was still high

  • What is the output of ps aux while the load is high?

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I don't see anything in that list that is generating high load. Was it high when you got the output of ps? I can understand why an RPi would be busy running plex, adguard, s6, duplicati, and qbittorrent though.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I don't see anything in that list that is generating high load. Was it high when you got the output of ps? I can understand why an RPi would be busy running plex, adguard, s6, duplicati, and qbittorrent though.

    I'll see If I can get it the load to a 11 again - then run the command - If I leave it on for at least a day the numbers will slowly keep creeping up

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!