Mergefs - "File name too long" error

  • I'm trying to use MergeFS plugin on my new OMV6 installation. When I merge 2 of my shared folders (each one pointing to a folder named "media" on different disks), everything is ok. However, if I try to add a third shared folder (again, pointing to a folder named "media" on a third different drive), then I get this error:


    If I run systemctl status srv-mergerfs-media.mount, I get this:


    Code
    srv-mergerfs-media.mount - MergerFS mount for media
         Loaded: error (Reason: Unit srv-mergerfs-media.mount failed to load properly: File name too long.)
         Active: inactive (dead)
          Where: /srv/mergerfs/media
           What: /srv/dev-disk-by-uuid-00259a2c-d4c1-4c25-8464-6f6d7e10ea74/media/:/srv/dev-disk-by-uuid-814e4bb0-de6d-4587-946d-c11316764bf5/media/:/srv/dev-disk-by-uuid-e3ba9cb9-e610-4b98-ad8f-87bc4e4099db/media/

    (Notice the three paths I'm trying to merge, showed above. The third path I'm trying to add is the /srv/dev-disk-by-uuid-814e4bb0-de6d-4587-946d-c11316764bf5/media. If I just add the other two, I don't get this error)


    I've tried to google this, but I have no clue where to start digging... Any help will be appreciated.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!