Configuration issue while mounting pre-existing hard drive

  • Hi everyone,

    After much effort to resolve this by myself and consulting previous posts/threads from this forum and reddit, I call for your help and knowledge, and also for future google search reference.

    I periodically plug in an offsite backup (USB hard drive) onto which I use Rsync to do specific folder backups. I've done this for years since the days of OMV4 and have not got any issue (while my config stayed pretty much the same).

    When I mount the drive under Storage>Filesystems>+Mount, I now get the following error while applying change from the Web-GUI:

    I've found multiple threads with similar issue although not exactly the same error and tried their solutions. The main one was to look for drive UUID duplicates under the 2 following config file but I did not have any.



    The error message seems to report a specific function getting 2 arguments instead of 1 and the following fsname is given : 008530ff-a134-4264-898d-9ce30eeab927

    I've looked everywhere I could think of to find this tag but it does not seems to be associated to any of my drive (not found in two specified files above neither).

    Note that sdi1 is the problematic drive. The output of lsblk -f shows symptoms of the problem:

    Important note : I am able to manually access the disk to the actual mount point (/srv/dev-disk-by-uuid-187d7325-f60d-4d38-8762-54f6a30a20c4/) using sftp even if lsblk reports this random mounting point.

    I would like to find the bottom of it since I feel like the problem comes from my config and not the drive itself (wipping and redoing entire backup would work but the problem could come back again).

    General info :

    • OMV is up to date.
    • OMV is directly installed on PC. Not running in container nor using proxmox kernel.

    Previously tried solution that gave same error :

    • Unmounting & unplugging drive, replug and remount.
    • Unmounting & unplugging drive, reboot, replug and remount.
    • Reboot after trying to applying change & getting error and keeping drive plugged in.
    • Installed drive on different PC and drive is running OK.

    Thanks for your help, you guys are awesome!


  • geaves

    Approved the thread.
  • KM0201

    Approved the thread.

    After narrowing down the issue to diskstatplugin, I tried uninstalling it and received the following error :

    Well, these 4 not fully installed or removed packages were the problem... apt upgrade fix them up (apt update were reporting no package to upgrade, this is why these "not fully installed package" got under my radar).

    Happy ending, I will tag the issue as resolved.


    Sincerly yours,


    6.4.0-1 (Shaitan)

    Kernel : Linux 5.10.0-22-amd64

    Intel B150 + G4560

    OMV is developped and supported by people on their spare time, please consider supporting them financially if you can 8)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!