Applying changes and updating shows error - after Python3 upgrade

  • Hi, after updating python3 to 3.10 with some help (I am using a Raspberry Pi) I tried to apply the configuration and this error message shows:

    Also, when I run apt update this happens:

    Traceback (most recent call last):  File "/usr/sbin/omv-mkaptidx", line 38, in <module>    import aptModuleNotFoundError: No module named 'apt'Reading package lists... DoneBuilding dependency treeReading state information... DoneAll packages are up to date.

    Can anyone help me? Thanks.

  • I managed to solve the issue.

    So I remembered that after I installed python3.10 the update command had this strange message.

    In my browsing history I found the guide I followed to install python3.10.

    Then I searched for the python version that does not show an error when I try to import openmediavault:

    root@raspberrypi:/usr/bin# python3.10 -c "import openmediavault"
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
    ModuleNotFoundError: No module named 'openmediavault'
    root@raspberrypi:/usr/bin# python3.7 -c "import openmediavault"

    Then I followed the guide to make python3 call python3.7 instead of 3.10.

  • matefon

    Added the Label resolved
  • matefon

    Added the Label OMV 5.x

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!