OMV on Proxmox 7.4-3 dont read more than 1GB of RAM, assigned 16GB

  • Hi Community, good day and nice to meet you.


    I need some help with my setup, unfortunately i didnt found a solution on internet.

    I have an OMV 5 running in my proxmox server. this vm have 16GB od ram assigned but can only read and use 1GB.


    I tried to adjust this but was not able. how can i fix this?



    VM profile


    VM settings:


    I already tried a lot of settings, adjusts and nothing worked.


    Thanks in advance.

  • I have tried OMV on Proxmox out of interest and have found 2 GB has been more than enough. Depends what you are doing of course. My standalone server has 16 GB rarely uses more than 2 GB, this is streaming four videos on Jellyfin. I only have 16 GB (2 x 8 GB) to speed up dual channel RAM for transcoding. I suspect there is nothing wrong at your end.


    Edit - just looked at your first pic more closely - now not so sure. But here's my standalone system like yours not as expected.


    Code
    root@omv:~# free -m
                   total        used        free      shared  buff/cache   available
    Mem:           15858        1611        6504           6        7743       13911
    Swap:           8059           0        8059

    Inwin MS04 case with 315 W PSU

    ASUS Prime H310i-Plus R2.0 board

    Two port PCI-E SATA card

    16GB Kingston DDR4

    Intel Pentium Coffee Lake G5400 CPU

    Samsung Evo M.2 256GB OS drive

    4x4TB WD Red NAS drives + 1x4TB + 1x5TB Seagate drives - MergerFS pool

    Seagate 5TB USB drives - SnapRAID parity x 2

    Edited once, last by johnvick ().

  • Thanks for your time johnvick. I was able to solve it yesterday morning by installing proxmox kernel on it, change hotplug options on vm profile, shutdown and start again.


    Now i am able to use 16GB on mt OMV 5. This storage is used to mount a zfs pool from an old and retired FreeNAS. this zfs pool is nfs mounted on an Emby server where i host my own media, working smooth now with 4k media using HDR..


    Thanks once again.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!