Some dashboard tiles broken after updating to OMV to 6.7

  • changes by omv gui are done but not applied" as well.

    What do you mean with this?

    What happens and how to reproduce it?

    Screenshots and pasted errors do wonders.

  • What do you mean with this?

    What happens and how to reproduce it?

    Screenshots and pasted errors do wonders.

    Hi Soma, I am missing the yellow banner on top asking me to "apply" settings afte having done somm configuration by OMV web gui.


    Sorry, no screenshot possible due it will not show up any more. But I mean the yellow banner you are talking about in



    So if I make a change by OMV gui nothing happens. If I check again settings, it is still set but due missing apply button nothing happens. For example changing gui to https:// access it is done but not working. No yellow banner. No pending configuration. Nothing.


    Been able to take some screenshots. Changing back ssl/tsl secure connection - after pressing "save" just a green confirmation. no yellow "apply pending configuration" banner on top

  • Zoidberg  OMVPeta


    Can you please run on CLI:

    sudo omv-upgrade and see if everything is OK after? (should be)


    Ok, on the GUI, go to System-> Update Managment-> Updates and click on the Magnifying Lens to search for new updates and update from there to 6.7.0-3

    • Official Post

    Upgrade to version 6.7.0-3.

  • After installation of the 6.7.0.3 when I try to apply the changes, I got error: 500-Internal server error:...


    Some suggestion to fix it ?

    Thanks

    Have you tried to clear the browser cache?

    Ctrl+Shift+R

  • Now I have this strange behavior.

    I have an RPI4B SBC with Raspberry OS 64bit lite updated, OMV 6.7.0.3.

    I have attached 1 HD SSD 1TB EXT4 and all is OK.


    If I try to attach the 2nd HD 4TB NTFS with the USB hub with power supply, so no power problems, and in OMV GUI I see it in Disks folder but when I mount it in File Systems, the window to select it as already with a file system, doesn't select any drive...



    I have tried the HD on Wind10 and it works.

    I need this NTFS because sometimes I need to update some files from the PC WIn10...


    Any suggestions ?

    Thanks

    Ant

  • This seems to only affect Raspberry, I guess everyone who has reported here uses Raspberry.

    I just tried the update in a vm and although the screen got stuck after updating, Ctrl+Shift+R resolved it and the GUI is still fully operable without errors.

    I can confirm this. I run two instances of OMV: one on a Raspberry Pi 4, and one on an E5-2690. I always update both machines at the same time every morning. This morning when I booted up the dashboard on the Pi was showing all red warnings, and wouldn't load the update status. My other instance was fine. Switching to the system tab I was able to install today's update and it is fixed.

  • Both issues are solved (tiles+apply settings banner) with the latest update, thanks a lot.

    OMV 6 running on an odroid HC4 board with 2 4TB sata HDD

  • Someone has a suggestion to solve this issue ?

    Thanks Ant

  • Many thanks also from me. 😊


    The btrfs filesystem could be mounted via GUI again, also all other configurations could be executed via GUI again.


    Unfortunately the dashboard shows the wrong free capacity of my btrfs filesystem (I originally created a btrfs array from two 12TB HDD via CLI during the first OMV installation).


    I don't want to misuse this post for this problem, but I would be grateful for a suggestion to solve the problem.


    I have already searched the web and am hopeful that I can solve the issue with "btrfs balance".


    (Sorry, I am still a very inexperienced Linux/btrfs user. 🫣)


    Apart from that I just made a PayPal donation to the OMV project as an appreciation of the great open source work. 👍👍

    • Official Post

    Could you please run btrfs fi show <DEVICE> and btrfs fi df -b <DEVICE> and btrfs inspect-internal dump-super <DEVICE> and post the output here.

  • Could you please run btrfs fi show <DEVICE> and btrfs fi df -b <DEVICE> and btrfs inspect-internal dump-super <DEVICE> and post the output here.

    This is output:


    sudo btrfs fi show /srv/dev-disk-by-uuid-d4550281-2f08-4c98-a828-ab38dd959c7c/


    Label: none uuid: d4550281-2f08-4c98-a828-ab38dd959c7c

    Total devices 2 FS bytes used 4.97TiB

    devid 1 size 10.91TiB used 5.43TiB path /dev/sda

    devid 2 size 10.91TiB used 5.43TiB path /dev/sdb



    sudo btrfs fi df -b /srv/dev-disk-by-uuid-d4550281-2f08-4c98-a828-ab38dd959c7c/


    Data, RAID1: total=5966783315968, used=5455739400192

    System, RAID1: total=8388608, used=868352

    Metadata, RAID1: total=7516192768, used=6026444800

    GlobalReserve, single: total=536870912, used=0



    sudo btrfs inspect-internal dump-super /srv/dev-disk-by-uuid-d4550281-2f08-4c98-a828-ab38dd959c7c/


    ERROR: failed to read the superblock on /srv/dev-disk-by-uuid-d4550281-2f08-4c98-a828-ab38dd959c7c/ at 65536

    ERROR: error = 'Is a directory', errno = 21



    sudo btrfs filesystem usage /srv/dev-disk-by-uuid-d4550281-2f08-4c98-a828-ab38dd959c7c


    Overall:

    Device size: 21.83TiB

    Device allocated: 10.87TiB

    Device unallocated: 10.96TiB

    Device missing: 0.00B

    Used: 9.93TiB

    Free (estimated): 5.94TiB (min: 5.94TiB)

    Free (statfs, df): 5.94TiB

    Data ratio: 2.00

    Metadata ratio: 2.00

    Global reserve: 512.00MiB (used: 0.00B)

    Multiple profiles: no


    Data,RAID1: Size:5.43TiB, Used:4.96TiB (91.44%)

    /dev/sda 5.43TiB

    /dev/sdb 5.43TiB


    Metadata,RAID1: Size:7.00GiB, Used:5.61GiB (80.18%)

    /dev/sda 7.00GiB

    /dev/sdb 7.00GiB


    System,RAID1: Size:8.00MiB, Used:848.00KiB (10.35%)

    /dev/sda 8.00MiB

    /dev/sdb 8.00MiB


    Unallocated:

    /dev/sda 5.48TiB

    /dev/sdb 5.48TiB



    Screenshots shows btrfs file system in GUI and this is what I don't understand. Why seems brtfs filesystem to be out of space (red bar in both screenshots)?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!