Docker container is not reachable in network

  • I have set up a guacamole container and want to connect via ssh to a raspberry pi 4 with adguard on it. It doesn't work and when I try to understand why I get other problems.


    So my guacamole container is reachable by my host server (I can ping the container) and everything on my server. My server can reach other devices over the network and ping works.

    When I try to ping my Pi with adguard my Pi is reachable.

    When I now try to ping my guacamole container on the server from my Pi with adguard in my network via the container ip 172.18.0.2 or via the server IP with port 192.168.xxx.xx:8222 it is not reachable (100% packet loss). I can reach the guacamole container over 192.168.xxx.xx:8222 in browser but I cannot ping the container and ssh also won't connect.

    I have looked into the firewall rules, but I haven't changed anything from the default. How am I able to reach my guacamole container? I have searched many tutorials, guides and posts, but I haven't got any idea on why it is not working.


    any ideas?

  • You can not ping a port.


    The IP 172.18.0.2 is not accessible from outside a container.


    If ssh will not connect, is sshd running on an accessible port?


    Try to get a better understanding of networking principles.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 7.x on headless Chenbro NR12000 1U 1x 8m Quad Core E3-1220 3.1GHz 32GB ECC RAM.

  • Yes I have ssh over port 55 accessible.

    The container has a port opening on 8222 and is accessible over browser and RDP to windows connection also works but why the ssh connection not.

    sshd is running and it will connect to any pc in the network but not to my guacamole container. I have checked username password, everything is correct. I mean my server is also in the network so I should not have to open ssh over a remote connection.

  • I have no idea at all what it is you are trying to do.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 7.x on headless Chenbro NR12000 1U 1x 8m Quad Core E3-1220 3.1GHz 32GB ECC RAM.

  • What I want to achieve -> Get ssh access to my RPI from my guacamole container on my server.


    What is the problem -> guacamole container is accessible and is able to make a RDP connection to a windows pc on my network but no ssh connection to my RPI. Doesn't matter what device on my network I want to get a ssh connection, it will not work.


    The only ssh connection that works on the guacamole container is to the host server. But anything outside the server (everything else in my network) there is no ssh connection possible.


    I feel this is a bit weird because if the container would not be able to connect to a device outside the host server, the RDP connection to a windows pc in the network would not be possible. So the question is, what is causing the ssh connection issue.

  • In order to form an ssh connection, you must have an ssh client, an ssh server, and an interconnecting network free of any applicable of encumbrances.


    Which part or parts are you missing?

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 7.x on headless Chenbro NR12000 1U 1x 8m Quad Core E3-1220 3.1GHz 32GB ECC RAM.

  • Mhm..my guess would be the ssh client because the container does not provide one. But it could use the host (server) ssh client.


    Other tutorials don't mention anything complex to set up ssh. They just go to settings and set up the credentials and that is it. I do the same but it does not work. Also, the RDP connection works, so the container should be able to communicate to the outside. I do not get why the guacamole container seems to not use my host ssh client to connect to an other device because if I set up the connection to my host it works.


    I could set up a ssh client container maybe and use it as a client for guacamole? But this would just be a workaround.

  • Copaxy

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!