Nobody folder shared by samba

  • I have set OMV7 (7.0-29) with three users, six shared folders, but only three shared by samba plus home directories. I also have KVM with one VM.

    One of the samba shares (Public) is set with guest only permission. The others are no Public.


    Mysteriously, I now have a folder being shared called nobody.


    It doesn't exist on the disk. It doesn't disappear if I disable the Public guest share. It doesn't disappear if I change minimum samba version from 3 to 2. It does disappear if I turn off home directory sharing. So I take it that it is the nobody user being picked up by samba. I suppose I could add,


    [nobody]

    browseable = no


    to smb.conf but that seems to be a bad idea since smb.conf is managed by OMV.


    Has anyone else run into this?

  • Krisbee Yes, I saw the thread. It is smb version 4.17.12-Debian so it appears to be the same thing.


    I just tried 'access based share enum = yes' and I thought it would have worked but instead it hid the homes folder and left the nobody folder visible. No my reading of the docs. ;)


    I think for the moment I will just leave it. OMV7 is RC1 so things are going to change and I would rather not mess around with it to much in case it trips me up later (I have not been documenting my setup). That being said, the chance of a version change in debian is rather small.

  • The suggested fix in the Debian forum does work. For example:



    Code
    root@omv:/etc/samba# cat /etc/samba/smb.conf.d/home.conf
    [nobody]
            browseable = no
    
    root@omv:/etc/samba#


    The "nobody" folder no longer appears.

  • Considering this affects the RC for OMV7, do you think I should report it as a bug? Otherwise, with little prospect of a change in version from Bookworm, this is going to pop up in every installation of OMV7 for years to come.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!