openmediavault-emby plugin (formerly mediabrowser)

  • Can you remove the video libraries and try some music mp3s??? Just curious to see if the mp3s work. Trying to see if this is issue with mp4s or something worse. I want to verify that the server is working.

  • Nope mp3 is also not working.
    Exactly the same like mp4 or mkv.
    Somehow the scan has no result.

    Okay I reinstalled the Plugin and now its working lol
    Could've tried that earlier :D

  • Yeah with the exact sam samba share its working right now.
    What I did which could be a Problem was:
    I moved the DB location after the inital setup.
    Maybe there went something wrong...

    This time i added the location first and then did the setup and everything went fine.

  • Auto Organize is not working at my setup due to permissions.
    Now that I know you ( tekkb) are pretty skilled regarning permissions and stuff hopefully you can help.

    I get this error:

    13:41:51 UTC 2016)
        Application Path: /opt/emby/MediaBrowser.Server.Mono.exe
        Access to the path is denied.
          at System.IO.File.Move (System.String sourceFileName, System.String destFileName) <0x7f6cdc7000c0 + 0x002f0> in <filename unknown>:0 
          at CommonIO.ManagedFileSystem.MoveFile (System.String source, System.String target) <0x413d19b0 + 0x00022> in <filename unknown>:0 
          at MediaBrowser.Server.Implementations.FileOrganization.EpisodeFileOrganizer.PerformFileSorting (MediaBrowser.Model.FileOrganization.TvFileOrganizationOptions options, MediaBrowser.Model.FileOrganization.FileOrganizationResult result) <0x413d1350 + 0x001a0> in <filename unknown>:0

    As far as I can see this the emby user does not have Permission to my Download and/or media Folder/s.
    So I believe I need to create the user in omv but I need to set a password which should not be necessary because right now the emby is already running as emby user afaik.

  • When people are downloading files the chmod and chown are incorrect a lot of the time. Move the files where you want them in your media share. Then in the shared folder section there is a reset permissions TAB. In that tab select your media shared folder and then use the default drop down for permissions. It will correct any permission issues and all your media files should work with emby or plex.

  • The Media files are working correctly but not automatically moved by emby because like explained above the permission is missing.
    I think i need to give the permission to folder to them emby system user but dont know how to do so.

  • The emby user does not need permission. All it needs is the 4 value (read only) for others, the last value chmod 744. The reset permissions thing will do this and add it to the users group. One thing to keep in mind though if you reset permissions your chown will be root:users. The user you created to move files into the samba share will no longer be able to delete the file. If you want that user to still be able to delete the files by accessing the samba share from another computer you should do a recursive chown on your media share manually.

    Change directory to one level above the folder you want to chown and:
    chown -R olli:users foldername

    BTW, I normally do chown commands via command line versus the reset perms for this very reason. I want my user to still be able to delete files when accessing the samba share via Windows. Only the owner of a file can delete it while accessing via samba.

  • Hello,

    I have a problem with emby. While scanning my library, it crashes (I need to do a service emby start to make it work again and it crashes later (while scanning the library...)
    I have made a post on the emby support forum and they tell me that I have to use mono because they have problems with the 4.4…er-crashes-when-starting/

    Unfortunately, I have no idea how to install an old version of mono :(
    Can you please help me?
    Thank you

  • 4.4 is working for me. I have seen this issue on the emby forums. I don't know what the difference is between our systems. It seems to be hit and miss with 4.4.

    (Note: some of these commands may do nothing but go through them completely)
    apt-get purge mono*
    apt-get purge libmono*
    apt-get purge openmediavault-emby
    apt-get autoremove

    Then disable the mono repo in OMV Extras.

    Now create a new mono repo:
    cd /etc/apt/sources.list.d
    touch mono-xamarin.list

    Use nano and put this line in the mono-xmarin.list file:

    deb wheezy/snapshots/ main

    apt-get update

    Then install the plugin again.

  • Hello,

    Thank you for your tie, but I have a problem doing it.
    I have a message telling me that
    E: Le type « » est inconnu sur la ligne 1 dans la liste des sources /etc/apt/sources.list.d/mono-xamarin.list
    E: La liste des sources ne peut être lue.

    Also, when you say to install the plugin again, you mean that I have to enable mono repo and then Emby again, is it correct?


  • Hello,

    Thank you again.

    Now I have the following error message (conflict )
    Lecture des listes de paquets... Fait
    W: Distribution en conflit : wheezy/snapshots/ Release (wheezy/snapshots attendu, mais wheezy obtenu)

    How can I install the Emby plugin without the Mono repo?

    EDIT :
    I have added a "." in the file to make it work.
    After that, I have edited omv-extras-org-stoneburner.list to remove the line with mono and I was able to install the Emby.
    I can't move the datafolder at the moment.

    deb wheezy/snapshots/ main
  • Good morning,

    Yesterday I all of a sudden noticed Emby which has been running perfectly for ~month was enable but not running (red light). In the OMV gui I could not restart, unenable/enable to restart it. I then took the nuclear approach and uninstalled the plugin via OMV gui and then reinstalled it. Since then I cannot get emby to scan library without crashing. I have tried each of my media types individually (ie movie, TV Shows, etc) and emby stops scanning at different percent times. I have tried the apt-get purge openmediavault-emby and then OMV gui multiple times and still keep getting emby to crash during the Scan Library. Any suggests would be greatly appreciated.

    My system: CPU Intel Core i3-4130 Haswell with 16GB memory, drives are separate ext4 without raid, SMB is used to share to my Windows PCs

    OMV: ver 2.2.5
    Emby: present one: ver 3.0.5972.0

    Emby logs: I don't know which *.txt file to look at


Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!