Shellinabox plugin in testing repo

  • Ah, I thought you meant the button in the Dienste/Shellinabox. This just means the service is not running.


    What processor are you using?
    What happens when you do this in command line?
    service shellinabox start


    What does it say?

  • Just in opposite to the service window.

    Code
    root@NAS:/etc/init.d# service shellinabox start
    /usr/bin/shellinaboxd already running.


    I don't know, if this is somehow related, but I want to mention that the last days, I tried to get vdr plugin fully working (other thread)
    I tried my best (I am not a Linux expert) to get this working. At the beginning there was Live and VDRAdmin-AM running, but not Streamdev.
    After my unexperienced doing, currently Live and Streamdev is running but not VDRAdmin-AM

    Code
    Konnte Verbindung zu localhost:6419 nicht aufbauen: Access denied!
    Bitte überprüfen Sie, dass VDR läuft und dass seine svdrphosts.conf richtig konfiguriert ist.


    I checked svdrphosts and all that stuff and I did that using shellinabox. Just at this doing shellinabox stopped working, so I am wondering, if this is somehow related.

  • CSP could block the werb client that you use in the OMV GUI but if you open up a separate TAB on your browser and use the address there should not be some security issue. You do not even get the warning about SSL??? The certificate being used is not signed so you should get a warning. It is hard to tell exactly what is going on without getting on the machine. Are you using the firewall???


    Is ssh working OK via Putty???

  • Quote

    CSP

    what is CSP?


    No I don't get a warning about SSL. And I don't use OMV firewall (should I?). The webinterface did not work on Windows, also not in Ubuntu tested on three different browsers (chrome, Firefox, IE)
    ssh works perfekt in Ubuntu, also with putty in Windows.
    What else can I do?

  • OK some news. If I deactivate shellinabox in OMV, than put in Terminal

    Code
    root@NAS:~# sudo /etc/init.d/shellinabox stop
    root@NAS:~# sudo /etc/init.d/shellinabox start


    I can insert


    Code
    https://NAS:4200

    in the browser and shellinabox opens, after blaming arround about missing cert. The "https" is then red colored and strikethrough.
    If I then activate shellinabox again in OMV and

    Code
    https://NAS:4200

    , there is an Error code

    Code
    Fehlercode: ERR_CONNECTION_REFUSED
  • in the browser and shellinabox opens, after blaming arround about missing cert. The "https" is then red colored and strikethrough.


    This above is normal... So it works one time and then it will not connect again? What browser are you using? Have you tried different browsers. It is like it is being blocked due to the non signed certificate or something. What is the computer you are using to connect to the OMV?


    BTW- this plugin has worked pretty much without any problems. Only a few people complained because they wanted more features, like to be able to choose port.


    PS- CSP=Content Security Policy

  • Quote

    What is the computer you are using to connect to the OMV? What browser are you using?


    - Medion Desktop PC==> Ubuntu 14.04 ==> Chromium(mainly), Firefox
    ==> Win 7, ==> Chrome


    - HP EliteBook 2540==> Win 7==> Chrome, IE


    Have tested all variations ==> all the same


    Quote

    BTW- this plugin has worked pretty much without any problems. Only a few people complained because they wanted more features, like to be able to choose port.


    It's not so much that I urgently need shellinabox, but the feeling there is something signficant wrong e.g. hackers.
    I would also consider to install OMV again from scratch (I still have my data on a Synology NAS), but if I do that, it's maybe the same afterwards.

  • You can do this without doing a complete reinstall via ISO.


    apt-get --reinstall install openmediavault



    It will not hurt any of your data. I don't think it is hacker issue. Something was probably messed up when you were using the VDR plugin.


    What are you using for your system drive???

  • [quote]I would also consider to install OMV again from scratch (I still have my data on a Synology NAS), but if I do that, it's maybe the same afterwards.


    Try installing OMV in a VM and see if you can get the plugin working.

    omv 5.5.2 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • BTW thanks for helping me so much!


    Quote

    apt-get --reinstall install openmediavaultIt will not hurt any of your data.

    You mean installation is, like it was before e.g. plexserver just as an example? Than I will do it.


    Quote

    What are you using for your system drive???

    Yes another issue. :( I use a 250GB HDD. By accident, I saw this morning

    Code
    failed to enable aa (error_mask = 0x1)


    I tried to look, what this cold mean, but found not more than, it's may not the healthiest anymore. I will perform a SMART Test to find out more. BTW GSmartControl would may be a nice feature in OMV!?


    I also activated email reporting, but I am simply overćharged with all the different types of messages.

  • Quote

    I would try a different hard drive or SSD for the system drive.

    I followed your advice and ordered a small SSD. Better to start up with a healthy system!
    When I get it, I will setup the system complete new, which is no tragedy as my datas are anyway still save on another NAS system.
    Inbetween I still want to test and learn. Therefore I found this advice very good proposal.


    Quote

    Try installing OMV in a VM and see if you can get the plugin working.


    I did that and again I am stuck. OMV installed perfectly on VM. I saw a proper installation in the included Terminal, but how can I log to the Webinterface? If this is the Remote Desktop Server Port ==> XYZ:9000, it's the same as with shellinabox :( , no connection

  • Find the ip address of the vm with ifconfig. Then from your desktop (host not client), go to http://ip_address/

    omv 5.5.2 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Quote

    Find the ip address of the vm with ifconfig. Then from your desktop (host not client), go to http://ip_address/


    Thanks, but I already did that. I found the problem inbetween in another thread

    Quote

    Shutdown your guest, change it to bridged network adapter and boot again


    That did the job.


    Edit:
    VM runs great! Seems better than the Original but shellinabox is not working either. Could it be a blocking from the router, or what can it be?

  • Yes weird. Even when I can not reproduce. As described above, when I stopped and started the service manually in the shell, I was able to log in. Now thats gone. Today I played arround with ssh settings in OMV Gui, after that I could lock into shellinabox. I quickly tried with both computers and all browsers and it worked. Restarted OMV and it didn't work anymore. Makes no sense for me. I can't believe this all is related to a HW error of HDD, but will see when I get the new one.

  • It is not your fault. There is a bug. I am trying to figure it out now.


    You always upgraded to version 1.14 ??


    I upgraded a vm and all my buttons that used linkedfields were grayed out. So it is not just you having this problem and it is not just the shellinabox plugin effected. Sent message to Volker.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!