Plugin "Web Interface in Tab" frames fail to work across the board

  • Hey gang.

    This feature worked once in the mists of time when I was testing OMV and long before I started using it live (I think it was early 0.5 Sardaukar) but after a reinstall on different hardware it never worked again. Here we are on OMV 1.0 and I've got a little bit of time to try and track the issue down.

    Pretty much any plugin, Couchpotato, SABnzbd, Sonarr, Sickbeard, Subsonic, you name it, if it's got a "Show tab containing XXXXXXX web interface frame." checkbox, then when you check it and go to the tab, there's absolutely nothing, just a white empty box. All of these plugins are fully functional (excepting Sickbeard as I'm using Sonaar at the moment) and can be reached by the "Show Web Interface" button or by directly going to the URL (works both ways). Settings are saved persistently through reboots - the tab's still there afterwards, but nothing shows up.

    Does anyone have any ideas what might cause this? Perhaps more importantly, is it worth the aggravation to bother? I have to access my OMV from the outside on port 443 ONLY, as every other high outbound port is blocked by MIS. So if I wanted to, for example, hit Couchpotato from the outside world, but sending to port 5050 is blocked on my work network, will the interface frame send it out via 443 along with the rest of the HTTPS session? If it doesn't, there's very little reason for me to bother, except to solve the issue due to curiosity.

    • Official Post

    They stopped working when OMV switched to nginx because the iframes are effectively disabled. If you want to enable it, install the links plugin and create a media tab or install the calibre plugin. Both allow enable iframes again.

    omv 7.1.0-2 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.13 | compose 7.2 | k8s 7.1.0-3 | cputemp 7.0.1 | mergerfs 7.0.5 | scripts 7.0.7 plugins source code and issue tracker - github - changelogs

    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • Install the openmediavault-links plugin. Then create a link and put a check mark in the media box. You can use a website like the forum.


    After you have made the link CSP will be disabled, the web clients should work, and you can delete the media link if you want in the links plugin.

  • I'm having the same problem with the the web tabs empty.

    I followed your instructions : installed the openmediavault-links plugin, create a link with media box checked but then the "change configuration - apply" fails (getting the message "An error has occured")

    Looks like a security setting is locking the system.

    Any idea ?

    Thank you.

  • No there is no space.

    Actually I can create the link as long as I do not select the media box.

    If I select the media box I get the error.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!