Can't access Samba shares

  • Setting up my server right now but I can't for the life of me get access to the samba shares on any computer!


    The shares show up on my macbook and my pc just fine but I can't go into the shared folder, in OSX I get "The operation can't be completed because the original item for "XXX" does not exist" and in Windows it says I don't have access rights. I have tried changing every setting possible from different users to only guests and creating groups and everything, it just won't work. I get the same error every time.


    I'm a total linux noob but I have some understanding and know a bit about the command line and such. I have checked the file system read/write rights on /dev and everything seems to be fine, users are allowed to read and write. Why won't it work? Im running 1.6.

  • Alright I did that, still exactly the same error. What can it be? The network? No matter what I do or what user I log into or whatever, I get exactly the same. Seems like the problem is higher up than the GUI somehow.

  • Yes I tried reboting the device, didnt run the command though, you run it anywhere when you are logged in via ssh?


    I don't think it will help though, if it doesn't work when I restart the entire server it shouldn't work when just restarting the service. Thanks for all the help so far, any idea what it can be? Anyone with similar problems?


    It keeps refusing me to access the shared folders no matter what I do.


  • fegga is my user


    could it be "inherit permissions = no"? I don't see an option for that in the GUI though, only for ACL.

  • Reset folder permission to default next to shared folder if you have omv extras. Let me know how it goes this time.

    How do you mean exactly? I don't have OMV extras btw, I plan on using it but haven't installed it yet because of this.
    You mean in Access Rights Management? I only have User, Group and Shared Folders.

  • I think I'm onto something now, I can't access the share from FTP either and when I look at the filesystem permissions for "media" its only for root. "media" is where all mounts and files and folders are located right? I'm really new to debian so its a jungle for me.

  • I kinda fucked up when I first started out with this, I went into root and renamed the media folder because I thought that was a folder I accidentally created in the GUI named exactly "media", I know it's stupid. I think OMV then just created a new media folder and maybe that messed up the access rights? Media isn't supposed to be available to look in for any other than root right? But the mounts and the subfolders inside have the right access rights on them, is this enough?


    I think I'm just gonna reinstall the whole OS and just wipe the drives and start over because I think I'm in some form of a deadlock situation here. Best thing to do right?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!