Posts by mbourd25

    Another update.


    Followed BernH advice and removed ther AMD GPU repositories since they are now integrated into the kernel.


    But now, I'm getting another error concerning the docker-compose while running the fix7to8upgrade script.



    Code
    Unpacking docker-compose-plugin (5.1.4-1~debian.13~trixie) over (5.1.4-1~debian.12~bookworm) ...
    dpkg: error processing archive /var/cache/apt/archives/docker-compose-plugin_5.1.4-1~debian.13~trixie_amd64.deb (--unpack):
    trying to overwrite '/usr/libexec/docker/cli-plugins/docker-compose', which is also in package docker-compose (2.26.1-4)
    dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
    Errors were encountered while processing:
    /var/cache/apt/archives/docker-compose-plugin_5.1.4-1~debian.13~trixie_amd64.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)


    How can I fix this? I tried all the solutions from the forums and the internet and could not fix this error.


    Thanks.

    Update. I was able to fix the 502 error by running commandsudo omv-salt stage run deploy.


    But now I am getting a new error when trying to update Docker-compose. Ran the fix7to8upgrade script to fix the and got repositories errors,


    Err:10 https://repo.radeon.com/amdgpu/6.1.3/ubuntu jammy InRelease

    Err:12 https://repo.radeon.com/rocm/apt/6.1.3 jammy InRelease

    E: The repository 'https://repo.radeon.com/rocm/apt/6.1.3 jammy InRelease' is not signed.


    How do I fix this?


    Thanks.

    OK. I think I may have fixed it by running command sudo apt-get -f install.


    But now, I can't login into the OMV web page. I enter the correct user id and password. But I get error "502 - Bad Gateway". I'm also afraid to reboot the OMV server thinking that I might not be able to connect to the server after reboot.


    Any suggestions?

    Thanks for your reply raulfg3 .


    I ran the fix7to8upgrade script and got this error,


    Rebuild apt index ...

    Creating index of upgradeable packages ...

    Creating index of plugins ...

    Traceback (most recent call last):

    File "/usr/sbin/omv-salt", line 28, in <module>

    import openmediavault.log

    ModuleNotFoundError: No module named 'openmediavault'

    Job for php8.4-fpm.service failed because the control process exited with error code.

    See "systemctl status php8.4-fpm.service" and "journalctl -xeu php8.4-fpm.service" for details.

    Done.

    Hi gang. I just got this error while trying to upgrade from OMV 7 to version 8.


    Errors were encountered while processing:

    /tmp/apt-dpkg-install-pydwQ5/030-docker-compose-plugin_5.1.4-1~debian.13~trixie_amd64.deb

    E: Sub-process /usr/bin/dpkg returned an error code (1)


    I looked thru to forum and also did a Google search for any solutions, but did not find anything.


    Let me know if any other information is required to try to resolve this problem.


    Any help would be truly appreciated.


    Thanks.

    Hi ryecoaaron

    Quote

    Nope. That is from Debian 10/OMV 5.

    It has been removed and ran commands omv-salt deploy run apt and omv-aptclean repos to reconfigure and update the repositories.


    Quote

    Is it causing a problem? Do you have a wifi adapter in the system? What is the output of: dpkg -l | grep -E "wireless-regdb|crda"

    I ran this command and no information is listed.

    Hi ryecoaaron , I just upgraded my server to OMV 7 and everything went very smooth except a couple of situations. I uninstalled the old beta Snapraid version, like you told me and reinstalled and the old array disappeared.


    But now, I get these error messages.


    1. I get this message for repositories:

    http://packages.azlux.fr/debian/dists/buster/InRelease: Key is stored in legacy trusted.gpg keyring (/etc/apt/trusted.gpg), see the DEPRECATION section in apt-key(8) for details.


    Do I need this repository?


    2. I keep getting this error, twice, when I boot up:

    platform regulatory.0: Direct firmware load for regulatory.db failed with error -2


    How can I fix this. I looked at the Debian wiki at https://wiki.debian.org/Firmware, and the explanation seem to think you know which firmware you are missing. Is there a way to find out which firmware I'm missing?


    Thanks in advance.

    Hi, I upgrade OMV from version 6 to 7 but all the plugins are still at version 6.


    I tried multiple ways to fix this. I even followed these instructions from this thread, RE: OMV migrated to V7 but plugins are still in V6. But it is still displaying plugins for version 6.


    I also reran the fix6to7upgrade script, sudo wget -O - https://github.com/OpenMediaVault-Plugin-Developers/installScript/raw/master/install | sudo bash. It is still showing version 6 plugins.


    Here is the output from the web page for plugins in my OMV 7


    Here's the output from command dpkg -l | grep openme

    Here's the output from command dpkg -l | grep openme

    Any help would be great. Let me know if more information is required.

    From the list of plugins that I sent you, should I remove any other plugin before proceeding with the upgrade to OMV 7?


    I should follow these steps to do the upgrade?


    1. Backup the OS drive (this is always a good idea, not only for upgrades)
    2. Make sure, you have enough free space on your OS drive
    3. If you installed software from foreign repos make sure they have a release for bullseye or remove the repos / software
    4. Go to the cli (Putty, ssh, keyboard) and run these commands (In case of errors stop and ask on the forum before making things worse)
      1. Make sure your current install is correct all configs can be deployed by running sudo omv-salt stage run deploy
      2. Get the current install up to date: sudo omv-upgrade
      3. Do the release upgrade by running sudo omv-release-upgrade
        If you see an error message from patch which says a patch has already been applied, ignore it. (this is the only error to be ignored)
    5. Wait for the last script to finish and reboot.
    6. Refresh/clear browser cache (Crtl-Shift R on most browsers)
    7. Check if all services and docker containers are running as you expect.
    8. If you see Linux image Updates you can not install on the UI, go to the cli and run omv-upgrade once more.


    Thanks again for your help ryecoaaron. It is truly appreciated.

    Hi ryecoaaron, That's my next goal, to upgrade to OMV 7.x. But had to replace my data drives since they started to give me SMART errors. WD Red hard drives are over 8 years old.


    Replaced them with brand new WD Red Pro.


    Here's the output from command dpkg -l | grep openme


    Hi gang, I created a new Snapraid array with new disks that I added to my OMV 6.0 installation to replace my older hard drives which they were setup with Mergerfs and Snapraid. I removed the Mergerfs setup and removed the Snapraid for my first array and OMV still uses my first Snapraid setup. Now I tried to delete my first array but I keep getting this error message,



    Is there a way I can delete my first array and have Snapraid point to the second array?


    Here is my Snapraid.conf file content.

    Any help would be great. Let me know if more information is required.


    Thanks in advance.