Just noticed that transcoding doesn't work anymore for Plex and Jellyfin. That's another topic.
Thanks again BernH for your help.
Just noticed that transcoding doesn't work anymore for Plex and Jellyfin. That's another topic.
Thanks again BernH for your help.
Finally got everything working.
Had to run command sudo dpkg -i --force-overwrite /var/cache/apt/archives/docker-compose_*.deb.
Then reran the sudo ./fix7to8upgrade script and all errors are gone.
Another update.
Followed BernH advice and removed ther AMD GPU repositories since they are now integrated into the kernel.
But now, I'm getting another error concerning the docker-compose while running the fix7to8upgrade script.
Unpacking docker-compose-plugin (5.1.4-1~debian.13~trixie) over (5.1.4-1~debian.12~bookworm) ...
dpkg: error processing archive /var/cache/apt/archives/docker-compose-plugin_5.1.4-1~debian.13~trixie_amd64.deb (--unpack):
trying to overwrite '/usr/libexec/docker/cli-plugins/docker-compose', which is also in package docker-compose (2.26.1-4)
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/docker-compose-plugin_5.1.4-1~debian.13~trixie_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
How can I fix this? I tried all the solutions from the forums and the internet and could not fix this error.
Thanks.
Thanks for your response BernH .
I'm wondering if I still need these drivers since I have an AMD 2200G CPU and I needed them before for transcoding videos for Jellyfin and Plex.
If I don't need them anymore, how do I go about removing them? Or should I add the newer ones?
Thanks again.
Update. I was able to fix the 502 error by running commandsudo omv-salt stage run deploy.
But now I am getting a new error when trying to update Docker-compose. Ran the fix7to8upgrade script to fix the and got repositories errors,
Err:10 https://repo.radeon.com/amdgpu/6.1.3/ubuntu jammy InRelease
Err:12 https://repo.radeon.com/rocm/apt/6.1.3 jammy InRelease
E: The repository 'https://repo.radeon.com/rocm/apt/6.1.3 jammy InRelease' is not signed.
How do I fix this?
Thanks.
OK. I think I may have fixed it by running command sudo apt-get -f install.
But now, I can't login into the OMV web page. I enter the correct user id and password. But I get error "502 - Bad Gateway". I'm also afraid to reboot the OMV server thinking that I might not be able to connect to the server after reboot.
Any suggestions?
Doing more investigating. My OMV 7 installation got screwed trying to upgrade to OMV 8.
I think I have no choice but to reinstall from scratch.
Anyone have any idea how I can avoid reinstalling OMV, would be greatly appreciated.
Thanks for your reply raulfg3 .
I ran the fix7to8upgrade script and got this error,
Rebuild apt index ...
Creating index of upgradeable packages ...
Creating index of plugins ...
Traceback (most recent call last):
File "/usr/sbin/omv-salt", line 28, in <module>
import openmediavault.log
ModuleNotFoundError: No module named 'openmediavault'
Job for php8.4-fpm.service failed because the control process exited with error code.
See "systemctl status php8.4-fpm.service" and "journalctl -xeu php8.4-fpm.service" for details.
Done.
Hi gang. I just got this error while trying to upgrade from OMV 7 to version 8.
Errors were encountered while processing:
/tmp/apt-dpkg-install-pydwQ5/030-docker-compose-plugin_5.1.4-1~debian.13~trixie_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
I looked thru to forum and also did a Google search for any solutions, but did not find anything.
Let me know if any other information is required to try to resolve this problem.
Any help would be truly appreciated.
Thanks.
Hi ryecoaaron
QuoteNope. That is from Debian 10/OMV 5.
It has been removed and ran commands omv-salt deploy run apt and omv-aptclean repos to reconfigure and update the repositories.
QuoteIs it causing a problem? Do you have a wifi adapter in the system? What is the output of: dpkg -l | grep -E "wireless-regdb|crda"
I ran this command and no information is listed.
Hi ryecoaaron , I just upgraded my server to OMV 7 and everything went very smooth except a couple of situations. I uninstalled the old beta Snapraid version, like you told me and reinstalled and the old array disappeared.
But now, I get these error messages.
1. I get this message for repositories:
http://packages.azlux.fr/debian/dists/buster/InRelease: Key is stored in legacy trusted.gpg keyring (/etc/apt/trusted.gpg), see the DEPRECATION section in apt-key(8) for details.
Do I need this repository?
2. I keep getting this error, twice, when I boot up:
platform regulatory.0: Direct firmware load for regulatory.db failed with error -2
How can I fix this. I looked at the Debian wiki at https://wiki.debian.org/Firmware, and the explanation seem to think you know which firmware you are missing. Is there a way to find out which firmware I'm missing?
Thanks in advance.
Thanks again for your help ryecoaaron , I thought both scripts were the same.
All plugins are now showing has being from version 7.
Hi, I upgrade OMV from version 6 to 7 but all the plugins are still at version 6.
I tried multiple ways to fix this. I even followed these instructions from this thread, RE: OMV migrated to V7 but plugins are still in V6. But it is still displaying plugins for version 6.
I also reran the fix6to7upgrade script, sudo wget -O - https://github.com/OpenMediaVault-Plugin-Developers/installScript/raw/master/install | sudo bash. It is still showing version 6 plugins.
Here is the output from the web page for plugins in my OMV 7
Here's the output from command dpkg -l | grep openme
Here's the output from command dpkg -l | grep openme
Any help would be great. Let me know if more information is required.
Hi, just to let everyone know I ran the fix6to7upgrade script from web site https://github.com/OpenMediaVa…-Developers/installScript and ran the wget script command directly on the Raspberry Pi, sudo wget -O - https://github.com/OpenMediaVault-Plugin-Developers/installScript/raw/master/install | sudo bash and everything is fixed now.
Thanks to everyone who created this script.
Hi, I got the same "502 Bad Gateway" error after upgrading to OMV7 on my Raspberry Pi when trying to login using the web page. But I'm also unable to log in using SSH. It will not accept the password.
What option do I have to fix this?
Thanks in advance.
Awesome. Thanks again. I'll keep you informed on how to upgrade went.
From the list of plugins that I sent you, should I remove any other plugin before proceeding with the upgrade to OMV 7?
I should follow these steps to do the upgrade?
Thanks again for your help ryecoaaron. It is truly appreciated.
Hi ryecoaaron, That's my next goal, to upgrade to OMV 7.x. But had to replace my data drives since they started to give me SMART errors. WD Red hard drives are over 8 years old.
Replaced them with brand new WD Red Pro.
Here's the output from command dpkg -l | grep openme
rc omvextras-unionbackend 5.0.2 all union filesystems backend plugin for openmediavault
ii openmediavault 6.9.16-1 all openmediavault - The open network attached storage solution
ii openmediavault-backup 6.1.1 all backup plugin for OpenMediaVault.
ii openmediavault-clamav 6.0.7-2 all openmediavault ClamAV plugin
ii openmediavault-fail2ban 6.0.3 all OpenMediaVault Fail2ban plugin
ii openmediavault-flashmemory 6.2 all folder2ram plugin for openmediavault
ii openmediavault-kernel 6.4.10 all kernel package
ii openmediavault-keyring 1.0.2-2 all GnuPG archive keys of the openmediavault archive
ii openmediavault-mergerfs 6.3.8 all mergerfs plugin for openmediavault.
ii openmediavault-nut 6.0.7-1 all openmediavault Network UPS Tools (NUT) plugin
ii openmediavault-omvextrasorg 6.3.6 all OMV-Extras.org Package Repositories for OpenMediaVault
ii openmediavault-resetperms 6.0.3 all Reset Permissions
ii openmediavault-rsnapshot 6.0.2 all OpenMediaVault rsnapshot backup plugin.
ii openmediavault-sharerootfs 6.0.3-1 all openmediavault share root filesystem plugin
ii openmediavault-snapraid 6.2.1 all snapraid plugin for OpenMediaVault.
Display More
Hi gang, I created a new Snapraid array with new disks that I added to my OMV 6.0 installation to replace my older hard drives which they were setup with Mergerfs and Snapraid. I removed the Mergerfs setup and removed the Snapraid for my first array and OMV still uses my first Snapraid setup. Now I tried to delete my first array but I keep getting this error message,
QuoteDisplay MoreFailed to execute XPath query '//services/snapraid/drives/drive[uuid='114a88d2-53ed-11ed-8eee-b3f2573b9c38']'.
OMV\Config\DatabaseException: Failed to execute XPath query '//services/snapraid/drives/drive[uuid='114a88d2-53ed-11ed-8eee-b3f2573b9c38']'. in /usr/share/php/openmediavault/config/database.inc:88
Stack trace:
#0 /usr/share/openmediavault/engined/rpc/snapraid.inc(172): OMV\Config\Database->get('conf.service.sn...', '114a88d2-53ed-1...')
#1 [internal function]: OMVRpcServiceSnapRaid->deleteArray(Array, Array)
#2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
#3 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('deleteArray', Array, Array)
#4 /usr/sbin/omv-engined(537): OMV\Rpc\Rpc::call('SnapRaid', 'deleteArray', Array, Array, 1)
#5 {main}
Is there a way I can delete my first array and have Snapraid point to the second array?
Here is my Snapraid.conf file content.
# This file is auto-generated by openmediavault (https://www.openmediavault.org)
# WARNING: Do not edit this file, your changes will get lost.
autosave 0
#####################################################################
# OMV-Name: DISK01 Drive Label: DISK01
content /srv/dev-disk-by-uuid-c0732fc4-6d0f-4898-a7d6-1cfc96625f59/snapraid.content
disk DISK01 /srv/dev-disk-by-uuid-c0732fc4-6d0f-4898-a7d6-1cfc96625f59
#####################################################################
# OMV-Name: DISK02 Drive Label: DISK02
content /srv/dev-disk-by-uuid-10994e9d-cb49-41c8-8f7d-da2815f0b096/snapraid.content
disk DISK02 /srv/dev-disk-by-uuid-10994e9d-cb49-41c8-8f7d-da2815f0b096
#####################################################################
# OMV-Name: PARITY1 Drive Label: PARITY1
parity /srv/dev-disk-by-uuid-27a7ad0c-8f34-4df0-8acf-6da1544221ef/snapraid.parity
exclude *.unrecoverable
exclude lost+found/
exclude aquota.user
exclude aquota.group
exclude /tmp/
exclude .content
exclude *.bak
exclude /snapraid.conf*
Display More
Any help would be great. Let me know if more information is required.
Thanks in advance.
Found the problem. The Portainer from omv-extras was enabled. That's not from me, since I install Portainer using docker-compose.
Thanks macom for your help.