Posts by myscha

    Hello,


    I'm posting this in Offtopic as it's not about a problem with OMV. If a mod thinks it would fit better into the NFS corner, please move it.


    I'm running an OMV server and it shares some directories via NFS with other Linux PCs in my LAN. On client side I have one line in /etc/fstab which mounts all subdirectories at once with the correct ro/rw access.


    Now I'd like to do the same with my HTPC. Therefore I took some lines from the servers /etc/exports and adapted it to the HTPCs directory structure:

    Code
    /data/dir1 192.168.178.123(fsid=1,rw,subtree_check,secure)
    /data/dir2 192.168.178.1/24(fsid=2,ro,subtree_check,secure,async)
    /data 192.168.178.123(ro,fsid=0,root_squash,no_subtree_check,hide)
    /data 192.168.178.1/24(ro,fsid=0,root_squash,no_subtree_check,hide)

    I try to share /data/dir2 to everybody in this subnet as read-only and /data/dir1 to a specific client as read-write. Unfortunately the OMV one-liner in /etc/fstab doesn't work with the HTPC exports. I have to add another line specifically for /data/dir1. Otherwise it's mounted as ro instead of rw.


    So my question is: does OMV do anything more special than this?


    What I really want is to share all children of /data as ro but /data/dir1 as rw.

    @lentorello


    In my case ASD always shuts the PC down (S5, "Herunterfahren").
    If I execute rtcwake -m no -u -t $(date -d '19:30 tomorrow' +%s) as scheduled job in OMV the PC wakes up fine every day. But it doesn't if I disable this job and let wakealarm do its work, although I didn't change anything in autoshutdown.

    Yes, I know. The advantage of the wakealarm plugin is that it is very comfortable to have more than only a few wakeup times and you can adjust the times easily. Using the scheduled jobs does not offer that comfort.


    Edit:
    And it doesn't explain why the stock version or my version above don't work.

    I think I solved it now. I made the following changes in /usr/sbin/wakealarm:

    Code
    import subprocess

    In the meantime I was able to figure out how OMV can be configured to deliver notification emails locally, without being overwritten by OMV.


    This can be achieved by setting the variables OMV_POSTFIX_MAIN_MYDESTINATION and OMV_POSTFIX_MAIN_INET_INTERFACES in /etc/default/openmediavault

    Code
    echo 'OMV_POSTFIX_MAIN_MYDESTINATION="server.local, server, localhost.local, localhost"' | sudo tee -a /etc/default/openmediavault
    echo 'OMV_POSTFIX_MAIN_INET_INTERFACES="localhost"' | sudo tee -a /etc/default/openmediavault


    In the GUI the following has to be set
    - Enable
    - SMTP server: localhost
    - SMTP port: 25
    - E-Mail sender: omv@localhost.home
    - Primary E-Mail: omv@localhost.home


    Test mails and notifications will be stored in /var/mail/omv afterwards. Now, only a service to fetch the mails via pop3 or imap is missing.


    EDIT:
    Some imap/ pop3 servers only work with emails in Maildir/ format and not with the default mbox format from above.
    To solve this, the line home_mailbox = Maildir/ has to be appended to the postfix config in /etc/postfix/main.cf. Therefore I created the file /usr/share/openmediavault/mkconf/postfix.d/15main_custom with the following content:

    Bash
    #!/bin/sh
    echo 'home_mailbox = Maildir/' | sudo tee -a /etc/postfix/main.cf

    which only appends the desired line to the postfix config. After restarting postfix it stores emails in the folder ~/Maildir.


    To be continued...

    My router (firewall) is configured so that the NAS has no internet access at all. But anyway I'd like to receive Email notifications, for example, about the disk health.


    Has anyone set up an email server on his NAS? What would be the preferable way: direct setup or via docker image? Are the tiny and easy to configure solutions?

    I'm running the latest OMV Arrakis together with the autoshutdown and wakealarm plugins. I configured autoshutdown in a way that it shuts the NAS down after some time of inactivity and wakealarm should wake the NAS up some hours later.


    This sequence works exactly one time, that means:
    - manually start the NAS
    - autoshutdown shuts it down
    - wakealarm wakes it up
    - autoshutdown shuts it down
    - NAS never wakes up again


    Every time I execute date -d @$(cat /sys/class/rtc/rtc0/wakealarm) it shows me the correct time on the correct day, athough I never had a look immediately before shutting the NAS down. So waking up by RTC is generally working, but anything happens after the first wakeup of the second shutdown.


    How can I debug this? Does anyone else have this problem?

    OK, it works by replacing .config/syncthing/https-cert.pem and .config/syncthing/https-key.pem and chown and chmod accordingly. But nevertheless one has to add another certificate exception in Firefox. This is because the exception is bound to a specific port and the webui and Syncthing ports differ. So it's no real advantage to use one certificate.

    I created a certificate and set OMV up to force HTTPS connection. For the webgui and all services I added myself, this works. But Syncthing created or brought its own certificate.


    How can I setup Syncthing to also use the OMV certificate?

    Instead of adding -o " include /srv/dev-disk-by-label-vol1/www/sites-enabled/*;" -n \ to /usr/share/openmediavault/mkconf/nginx.d/10webgui a less invasive solution is to create a new file in /etc/nginx/openmediavault-webgui.d/ and add the include there.


    Something like

    Bash
    echo "include /srv/dev-disk-by-label-vol1/www/sites-enabled/*;" > /etc/nginx/openmediavault-webgui.d/zzz-custom.conf

    I have nearly the same messages, but no problems up to now.


    There is no possibility to adjust the CPU voltage in the UEFI. Only the RAM voltage and that's already set to minimum. It allows only 1.5V and 1.35V