Posts by Joseph885412

    I did create a new drive. And now it works!

    I get to the login screen of Crashplan.

    Code
    dockeruser@omv5-vm2:/srv/dev-disk-by-label-1GB$ cd docker_crashplan
    dockeruser@omv5-vm2:/srv/dev-disk-by-label-1GB/docker_crashplan$ ls
    bin cache conf cp_version log machine-id repository var xdg

    Thank you so much for the help Morlan! I really appreciate it.


    I'm currently testing a new CrashPlan installation, so I might be back with more questions.

    Thanks Morlan.


    I did remove the shared folder /srv/dev-disk-by-label-500MB/docker_crashplan. I also removed dockeruser from sudo group.

    Then I created a new stack in portainer with this:

    The stack started and created the docker_crashplan folder and all it's subfolders. I was able to check it by SSHing in OMV:

    Still, Crashplan doesn't start normally. Still seeing this in the log:

    Code
    [CrashPlanEngine] starting...,
    [CrashPlanEngine] starting...,
    [CrashPlanEngine] starting...,
    [CrashPlanEngine] starting...,

    If I go on the Crashplan webpage, all I see is the Code42 splashscreen.

    Also:

    If I SSH into the OMV I can edit the zoubie.txt file like this:

    dockeruser@omv5-vm2:/srv/dev-disk-by-label-500MB/docker_crashplan$ sudo nano zoubie.txt

    Added some text. Saved it. Re-opened it and the changes were there.


    Also did this:

    dockeruser@omv5-vm2:/srv/dev-disk-by-label-500MB/docker_crashplan$ sudo mc (midnight commander)

    I could copy the zoubie.txt file to zoubie2.txt

    When you say "populate", how do I check that exactly?


    I could do this though:

    Using Windows Explorer, I did create a file, named "zoubie.txt", in the docker_crashplan folder.

    Then : crashplan-pro Container details: Console: /bin/sh: Connect

    The zoubie.txt file was there.


    The 1001:100 user is "dockeruser". It's member of users, sudo, ssh:

    uid=1001(dockeruser) gid=100(users) groups=100(users),27(sudo),115(ssh)


    When the docker_crashplan folder was created, I gave these permissions: Everyone:read/write.

    Then I did: ACL: And gave the user dockeruser Read/Write permission.

    Owner: dockeruser : Read/Write/Execute

    Group: users : Read/Write/Execute

    Others: : Read/Write/Execute

    Replace all existing permissions.

    Recursive: Apply permissions fo files and subfolders.

    Hi Morlan.


    Well, if I only mount the config (and not the Media folder), Crashplan doesn't start either. Like this:

    Hi,

    I want to setup a Crashplan-Pro Docker. I cannot make it work.


    Here's my Docker-Compose file:

    After starting the stack, I go check the container's log:

    I guess you noticed the:

    Code
    [CrashPlanEngine] starting...,
    [CrashPlanEngine] starting...,
    [CrashPlanEngine] starting...,
    [CrashPlanEngine] starting...,
    [CrashPlanEngine] starting...,
    [CrashPlanEngine] starting...,

    If I launch the Crashplan-pro webpage I see an error message: "Code42 cannot connect to its background service" "Retry".

    Sometimes I just see the Code42 splashscreen.

    I can see that the config folder works because Crashplan creates all it's confif files and folders in there.


    If I remove one volume line (- "/srv/dev-disk-by-label-500MB/docker_crashplan:/config"), the docker starts normally and I can see the login page. It's weird.

    I've tried creating a new shared folder for the config. Same behavior.


    Any ideas how to make this work?


    Here's the Container Inspect in Attachment.

    Container_Inspect.txt

    Sounds good ! Advantage of Duplicati is the WebUI.

    Good point! One of my projects only has a small dataset. So I'll try duplicati also.



    Any of those backup solutions that can make snapshots but stores them in folders with plain human readable data in original folder structures? For example, we could simply go to the latest snapshot and copy/download that folder to our computer.

    Just found an other one to add to the list : Restic.


    Apparently Restic+Rclone work well together. Restic can do snapshot backups to any cloud target supported by Rclone.

    https://restic.net/blog/2018-04-01/rclone-backend

    https://restic.readthedocs.io/…other-services-via-rclone


    I'm sure Duplicati works fine for many users. But I have the feeling that it's not optimal for large datasets. That's the feeling I've got from reading many posts in different forums. It just seems users who discovered Duplicacy are super exited about it ^^. But it's just a feeling. For now.


    I'm quite interested by Duplicacy right now. Found some articles praising it:

    -For large (+5TB datasets) : "Duplicacy demolishes duplicati and rclone for large backups"

    -An Ex-Crashplan/Duplicati user who is delighted by Duplicacy.


    Going to try it right away.

    I tried as a next step Duplicacy and indeed, it it is much faster as Duplicati. ... Next candidate is Cloudberry Backup for me hoping to find peace of mind on Linux and Windows and cross-platform use.

    Duplicacy seems a very good alternative to Duplicati. It creates snapshots in time, which I like. I'm considering it.


    CloudBerry seems nice. It seems it's now named MSP360 Backup. They also have a beta product: Image based backup for Linux (Full system backup.)!!!

    To be noted: The free version comes with some limitations:

    The Linux version is 149USD for ultimate (one time) : https://www.msp360.com/backup/linux.aspx

    Hi,


    I'm on OMV5.


    My system drive was getting too small so I've expanded the disk (VMware). I've also expanded the system partition.


    Now when I boot OMV it gives some error messages and then it boots normally. Here's the error messages:

    Code
    mdadm: No arrays found in config file or automatically
    mdadm: No arrays found in config file or automatically
    etc.
    .
    .
    Failed to start Enable File System Quotas
    See 'Systemctl status quotaon.service' for details



    Here's the result of : Systemctl status quotaon.service:



    Here's the result of : journalctl -xe


    Any ideas on how to fix those errors?

    You guys are scaring me... =O I think I'll go the docker route, or maybe look for an alternative to Duplicati.


    I did a debtree of mono-runtime on my system, just to see what's all the dependencies. It true, it's very complex. The good news is that it doesn't seem it would cause any conflict on my system. All we see are blue (Depends), black (Recommends) and green (Provides) arrows. There's no red (conflic) arrows. Anyways, it's a beast for sure. View the full image here: mono-runtime.zip


    What's a good alternative to Duplicati? The goal is to backup shared folders to Google Drive.


    Yes it exists:

    root@openmediavault:~# ls -al /run/systemd/resolve/resolv.conf

    -rw-r--r-- 1 systemd-resolve systemd-resolve 637 Jun 18 12:59 /run/systemd/resolve/resolv.conf


    Content of /run/systemd/resolve/resolv.conf:

    nameserver 8.8.8.8

    nameserver 1.1.1.1

    nameserver 64.6.64.6

    search local


    Deleted /etc/resolv.conf and re-created it as a symlink:

    root@openmediavault:/etc#sudo rm /etc/resolv.conf && sudo ln -s /run/systemd/resolve/resolv.conf /etc/


    Now we can see that resolv.conf is a symlink within the /etc/ folder:

    root@openmediavault:/etc# ls -la /etc/ | grep "\->"

    lrwxrwxrwx 1 root root 35 Jun 16 19:51 localtime -> /usr/share/zoneinfo/America/Moncton

    lrwxrwxrwx 1 root root 19 Jun 16 17:43 mtab -> ../proc/self/mounts

    lrwxrwxrwx 1 root root 21 May 2 16:39 os-release -> ../usr/lib/os-release

    lrwxrwxrwx 1 root root 32 Jun 18 13:14 resolv.conf -> /run/systemd/resolve/resolv.conf

    lrwxrwxrwx 1 root root 13 Jun 16 17:27 rmt -> /usr/sbin/rmt


    Checked content: It was empty...

    sudo nano /etc/resolv.conf


    Restarted systemd-resolved:

    systemctl restart systemd-resolved


    Checked content:

    sudo nano /etc/resolv.conf

    Now the content is:

    nameserver 64.6.64.6


    The name server I had set using omv-firstaid!!! :)


    Did reboot OMV to make sure everything stays as it is.


    Checked which DSN server was used using dig:

    root@openmediavault:~# dig twitter.com

    ; <<>> DiG 9.11.5-P4-5.1+deb10u1-Debian <<>> twitter.com

    ;; global options: +cmd

    ;; Got answer:

    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 6226

    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1

    ;; OPT PSEUDOSECTION:

    ; EDNS: version: 0, flags:; udp: 512

    ;; QUESTION SECTION:

    ;twitter.com. IN A

    ;; ANSWER SECTION:

    twitter.com. 391 IN A 104.244.42.193

    twitter.com. 391 IN A 104.244.42.129

    ;; Query time: 60 msec

    ;; SERVER: 64.6.64.6#53(64.6.64.6)

    ;; WHEN: Thu Jun 18 13:43:59 UTC 2020

    ;; MSG SIZE rcvd: 72


    It's 64.6.64.6 . So it stayed the same.


    Let's do another check:


    root@openmediavault:~# resolvectl status


    Global

    LLMNR setting: yes

    MulticastDNS setting: yes

    DNSOverTLS setting: no

    DNSSEC setting: allow-downgrade

    DNSSEC supported: yes

    DNSSEC NTA: 10.in-addr.arpa

    16.172.in-addr.arpa

    168.192.in-addr.arpa

    .

    .

    .

    Link 2 (ens33)

    Current Scopes: DNS LLMNR/IPv4

    DefaultRoute setting: yes

    LLMNR setting: yes

    MulticastDNS setting: no

    DNSOverTLS setting: no

    DNSSEC setting: allow-downgrade

    DNSSEC supported: yes

    Current DNS Server: 64.6.64.6

    DNS Servers: 64.6.64.6


    Now it seems that the Global DNS isn't used. It's the Link 2 DNS that is used.


    Cool!^^


    Thanks a lot ryecoaaron!! (I did send you a PM would you please check it?)

    It seems it's not a symlink:


    root@openmediavault:/etc# readlink -f resolv.conf

    /etc/resolv.conf

    root@openmediavault:/etc#


    And it seems that /run/systemd/resolved/resolv.conf doesn't exist... :

    root@openmediavault:/# cd /run/systemd/resolved/

    -bash: cd: /run/systemd/resolved/: No such file or directory

    root@openmediavault:/#


    Do you have an idea of what's going on?

    Yes it's started:



    But DNS queries uses the DNS server specified in : /etc/resolv.conf (which is 8.8.8.8 in my case) instead of the server I had configured with OMV web GUI (64.6.64.6)/etc/resolv.conf :




    I'm not sure but it seems that there's no symlink for /etc/resolv.conf. Do you know how to check this exactly? I've tried this and it doesn't output the file we're looking for: