Posts by gregeeh

    Hi all,


    I'm getting these upgrade emails:


    Code
    apticron report [Tue, 26 Mar 2024 10:24:06 +1100]
    ========================================================================
    apticron has detected that some packages need upgrading on:
    omv.localdomain
    [ 172.17.0.1 172.19.0.1 172.20.0.1 172.21.0.1 172.30.0.1 192.168.10.2 ]
    [ 192.168.32.1 192.168.96.1 ]
    The following packages are currently pending an upgrade:
    openmediavault-compose 7.1.2
    ========================================================================


    How can I stop these emails?


    TIA


    BTW - I don't use OMV to manage my containers. It is all done via Portainer.

    Seems the healthcheck is failing:


    Code
    root@omv:~# docker exec 36a4c795c771 wget --no-verbose --tries=1 --spider http://localhost
    Connecting to localhost ([::1]:80)
    wget: can't connect to remote host: Connection refused


    However this works:


    Code
    root@omv:~# docker exec 36a4c795c771 wget --no-verbose --tries=1 --spider http://127.0.0.1
    Connecting to 127.0.0.1 (127.0.0.1:80)
    Connecting to 127.0.0.1 (127.0.0.1:80)
    remote file exists
    root@omv:~#


    This is only failing since upgrading to OMV 7. Why??

    Thanks for your reply.

    Note: You posted the compose file without indents, I trust you have it written correctly on your system with the correct indents.

    Yes, it's a Portainer Stack so it would not work without the correct syntax. Just copied and pasted from Portainer.


    I will check the communicatation between the containers.


    EDIT: Fixed the indentation.

    At some point during the update did you change the port used by the OMV GUI to the default 80?

    OMV GUI has always used port 80 and still does. Here is the container stack:


    The container wallabag-wallabag is giving the unhealthy status.

    Hi all,


    Just updating OMV 6 -> 7 and all seems to be well except for one container staying in an unhealthy state. Seems this is the issue:


    Connecting to localhost ([::1]:80) wget: can't connect to remote host: Connection refused


    Would something of changed in OMV7 to cause this?


    TIA




    enable the docker repo in omv-extras.

    Thank you. Have enabled and run sudo omv-salt stage run deploy again. All errors are gone now and the summary is:


    Code
    Summary for debian
    ------------
    Succeeded: 2 (changed=2)
    Failed:    0
    ------------
    Total states run:     2
    Total run time: 154.080 s
    root@omv:~#


    Command seems to be working now:


    Hi all,


    Received an email this morning with this in it:


    Code
    /etc/cron.weekly/openmediavault-update-smart-drivedb:
    /usr/sbin/update-smart-drivedb: RELEASE_7_2_DRIVEDB/drivedb.h: download failed (curl: exit 28)
    run-parts: /etc/cron.weekly/openmediavault-update-smart-drivedb exited with return code 1



    Here's the result of running the command via CLI:


    Code
    root@omv:~# update-smart-drivedb
    /usr/sbin/update-smart-drivedb: RELEASE_7_2_DRIVEDB/drivedb.h: download failed (curl: exit 28)
    root@omv:~#

    Hi all,


    I don't have the Anacron Plug-In installed. OMV Version: 6.9.6-1 (Shaitan)


    I received this email this morning, here is the first part:


    Code
    /etc/cron.weekly/openmediavault-update-smart-drivedb:
    Download branches/RELEASE_7_2_DRIVEDB/drivedb.h with curl
    curl -f --max-redirs 0 -H Accept-Encoding: identity -o /var/lib/smartmontools/drivedb/drivedb.h.new


    As I've never received this email before I'm wondering why it has happened now?


    TIA

    I've just found that adding mount -a as a scheduled task to run at reboot has fixed everything. No more monit emails, and docker now starts after a reboot.


    Maybe a hint to the cause of the issue?

    Just rebooted and here is the output of journalctl -u docker . Just included date/time of today.





    For some reason the main storage drive, that also contains docker is taking a while to get mounted and that's the issue, I think. Docker is not waiting for the drive to be mounted before trying to start. My two cents.


    Hope all the above helps.