Wrong update to plexmediaserver-installer 1.10.1.4602-f54242b6b-1

    • OMV 3.x
    • Update

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Wrong update to plexmediaserver-installer 1.10.1.4602-f54242b6b-1

      Hi all!

      I updated a plugin via WEB UI

      Source Code

      1. Extracting readynas.deb ...
      2. >>> *************** Error ***************
      3. communication failure
      4. <<< *************************************
      5. rm: cannot remove '/etc/systemd/system/plexmediaserver.service.d/override.conf': No such file or directory
      6. Synchronizing state for plexmediaserver.service with sysvinit using update-rc.d...
      7. Executing /usr/sbin/update-rc.d plexmediaserver defaults
      8. insserv: warning: current start runlevel(s) (empty) of script `plexmediaserver' overrides LSB defaults (2 3 4 5).
      9. insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `plexmediaserver' overrides LSB defaults (0 1 6).
      10. Executing /usr/sbin/update-rc.d plexmediaserver disable
      11. insserv: warning: current start runlevel(s) (empty) of script `plexmediaserver' overrides LSB defaults (2 3 4 5).
      12. insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `plexmediaserver' overrides LSB defaults (0 1 6).
      13. Synchronizing state for plexmediaserver.service with sysvinit using update-rc.d...
      14. Executing /usr/sbin/update-rc.d plexmediaserver defaults
      15. insserv: warning: current start runlevel(s) (empty) of script `plexmediaserver' overrides LSB defaults (2 3 4 5).
      16. insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `plexmediaserver' overrides LSB defaults (0 1 6).
      17. Executing /usr/sbin/update-rc.d plexmediaserver enable
      18. Synchronizing state for plexmediaserver.service with sysvinit using update-rc.d...
      19. Executing /usr/sbin/update-rc.d plexmediaserver defaults
      20. Executing /usr/sbin/update-rc.d plexmediaserver enable
      21. Job for plexmediaserver.service failed. See 'systemctl status plexmediaserver.service' and 'journalctl -xn' for details.
      22. Done ...
      Display All


      Checked the /var/lib/plexmediaserver: is empty :cursing:

      I removed a package (apt-get remove plexmediaserver-installer) and I tried again in CLI but result is agint wrong:

      Shell-Script

      1. root@ovm:~# apt-get install plexmediaserver-installer
      2. Reading package lists... Done
      3. Building dependency tree
      4. Reading state information... Done
      5. The following package was automatically installed and is no longer required:
      6. avahi-utils (0.6.31-5)
      7. Use 'apt-get autoremove' to remove it.
      8. The following NEW packages will be installed:
      9. plexmediaserver-installer (1.10.1.4602-f54242b6b-1)
      10. 0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
      11. Need to get 0 B/7526 B of archives.
      12. After this operation, 0 B of additional disk space will be used.
      13. perl: warning: Setting locale failed.
      14. perl: warning: Please check that your locale settings:
      15. LANGUAGE = "en_US.UTF-8",
      16. LC_ALL = (unset),
      17. LC_CTYPE = "UTF-8",
      18. LC_MESSAGES = "en_US.UTF-8",
      19. LANG = "en_US.UTF-8"
      20. are supported and installed on your system.
      21. perl: warning: Falling back to a fallback locale ("en_US.UTF-8").
      22. locale: Cannot set LC_CTYPE to default locale: No such file or directory
      23. locale: Cannot set LC_ALL to default locale: No such file or directory
      24. Selecting previously unselected package plexmediaserver-installer.
      25. (Reading database ... 49840 files and directories currently installed.)
      26. Preparing to unpack .../plexmediaserver-installer_1.10.1.4602-f54242b6b-1_armhf.deb ...
      27. Unpacking plexmediaserver-installer (1.10.1.4602-f54242b6b-1) ...
      28. Processing triggers for systemd (215-17+deb8u7) ...
      29. Setting up plexmediaserver-installer (1.10.1.4602-f54242b6b-1) ...
      30. Downloading readynas package ...
      31. ######################################################################## 100.0%
      32. Passed checksum test.
      33. Extracting readynas.deb ...
      34. Synchronizing state for plexmediaserver.service with sysvinit using update-rc.d...
      35. Executing /usr/sbin/update-rc.d plexmediaserver defaults
      36. insserv: warning: current start runlevel(s) (empty) of script `plexmediaserver' overrides LSB defaults (2 3 4 5).
      37. insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `plexmediaserver' overrides LSB defaults (0 1 6).
      38. Executing /usr/sbin/update-rc.d plexmediaserver enable
      39. Job for plexmediaserver.service failed. See 'systemctl status plexmediaserver.service' and 'journalctl -xn' for details.
      40. root@ovm:~# systemctl status plexmediaserver.service
      41. ● plexmediaserver.service - Plex Media Server for Linux
      42. Loaded: loaded (/lib/systemd/system/plexmediaserver.service; enabled)
      43. Drop-In: /etc/systemd/system/plexmediaserver.service.d
      44. └─db_folder.conf
      45. Active: failed (Result: start-limit) since Tue 2018-02-13 22:45:04 CET; 2min 32s ago
      46. Feb 13 22:44:59 ovm systemd[1]: Failed to load environment files: No such file or directory
      47. Feb 13 22:44:59 ovm systemd[1]: plexmediaserver.service failed to run 'start-pre' task: No such file or directory
      48. Feb 13 22:44:59 ovm systemd[1]: Failed to start Plex Media Server for Linux.
      49. Feb 13 22:44:59 ovm systemd[1]: Unit plexmediaserver.service entered failed state.
      50. Feb 13 22:45:04 ovm systemd[1]: plexmediaserver.service holdoff time over, scheduling restart.
      51. Feb 13 22:45:04 ovm systemd[1]: Stopping Plex Media Server for Linux...
      52. Feb 13 22:45:04 ovm systemd[1]: Starting Plex Media Server for Linux...
      53. Feb 13 22:45:04 ovm systemd[1]: plexmediaserver.service start request repeated too quickly, refusing to start.
      54. Feb 13 22:45:04 ovm systemd[1]: Failed to start Plex Media Server for Linux.
      55. Feb 13 22:45:04 ovm systemd[1]: Unit plexmediaserver.service entered failed state.
      Display All


      How can get again a Plex Media Server?
      THX!
      Raspberry Pi3 | OMV 3.0.97 (Erasmus) | Armbian 5.33 | Plex Media Server
      CubieTruck (Cubieboard3) | Arch Linux ARM | Plex Media Server | openHAB2
    • I also had issues with Plex in the past. I recommend using the Plex image from their official website. I've read somewhere that the omv plugin has multiple issues and will be gone in some time.
      Just download the .deb from here , dpkg -i it and you should be fine.
      Your's Sincerely

      My NAS: OVM 3.x, 2x 3TB WD Red | Daily backup using rsync | Runing 24/7 for 3 years now without any failures :)
    • Noneatme wrote:

      I also had issues with Plex in the past. I recommend using the Plex image from their official website. I've read somewhere that the omv plugin has multiple issues and will be gone in some time.
      Just download the .deb from here , dpkg -i it and you should be fine.
      I recommend using docker...
      omv 4.1.13 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • cabrio_leo wrote:

      Noneatme wrote:

      Just download the .deb
      Which distribution did you use? I see only Fedora, Ubuntu, CentOS? Most likely Ubuntu, because it´s Debian-based.
      There are other posts here which recommend to use a Docker image as a further opportunity.

      I used the Ubuntu package. In my case, most prerequisites were already installed, so I think it should work out of the box on your machine too.
      But of course, you can also use a Docker image.
      Your's Sincerely

      My NAS: OVM 3.x, 2x 3TB WD Red | Daily backup using rsync | Runing 24/7 for 3 years now without any failures :)
    • Noneatme wrote:

      I also had issues with Plex in the past. I recommend using the Plex image from their official website. I've read somewhere that the omv plugin has multiple issues and will be gone in some time.
      Just download the .deb from here , dpkg -i it and you should be fine.
      I use Raspberry Pi3 image (OMV_3_0_88_RaspberryPi_2_3_4.9.41.img.xz) and reisntalled
      I will try install plexmediaserver-ros6-binaries-annapurna_1.11.3.4803-c40bba82e_armel.deb with dpkg
      Raspberry Pi3 | OMV 3.0.97 (Erasmus) | Armbian 5.33 | Plex Media Server
      CubieTruck (Cubieboard3) | Arch Linux ARM | Plex Media Server | openHAB2