not able to auto mount smb shares in linux mint

    • OMV 3.x
    • not able to auto mount smb shares in linux mint

      I have defined a smb share in OMV called 'photos'.
      On a linux mint desktop computer in the same network I can manually mount the smb share in Nemo through Networks>Windows Networks>network name>omv>photos
      Now I want to auto mount this share using fstab, so I mad this entry

      //omv/photos /media/pictures cifs username=myUserName,password=******* 0 0

      But I get this error: mount error(5): Input/output errorSearching on the web I found a possible solution to add argument ",sec=ntlm"

      //omv/photos /media/pictures cifs username=myUserName,password=*******,sec=ntlm 0 0

      But then I get: mount error(22): Invalid argument
      What am I doing wrong ?
    • Hallo,

      ich habe genau dasselbe Problem.

      Wenn ich einen Mountpunkt in meinem Home Verzeichnis erstelle wie hier:
      //10.11.11.33/linux /home/andreas/pernas cifs noauto,users,username=user,password=passwort,domain=WORKGROUP,sec=ntlm,vers=3.0 0 0
      Dann erhalte ich die Meldung:
      mount error(22): Invalid argument
      Refer to the mount.cifs[8]manual page (e.g. man mount.cifs)


      Wenn ich einen Mountpunkt unter /media erstelle wie hier:
      //10.11.11.33/linux /media/nastest cifs username=user,password=passwort,domain=WORKGROUP,sec=ntlm,vers=3.0 0 0
      Dann erhalte ich die Meldung im Linux Mint Dateiexplorer:
      Einhängen von nastest nicht möglich. Mount: only root can mount //10.11.11.33/linux on /media/nastest

      Ich denke das irgendetwas mit der mount.cifs nicht stimmt. Eventuell habt ihr ja einen Tipp für mich.
      Ich habe auch eine Synology ds218. Die SMB Freigabe der DS218 lässt sich problemlos in Linux Mint einbinden.
      Evtl. gibt es ja auch Settings die ich in OMV einstellen muss.