OMV 1.6, Sabnzbd plugin, permissions issue

    • OMV 1.0
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • OMV 1.6, Sabnzbd plugin, permissions issue

      I have a fresh install of OMV 1.6 and SABNZBD/Sickbeard plugin installed. I keep getting an error from SABNZBD while post-processing that it can't find the sabtosickbeard.py script, but it is pointing to the correct folder.

      Error message:
      File "/opt/sickbeard/autoProcessTV/sabToSickBeard.py", line 23, in <module>
      import autoProcessTV
      ImportError: No module named autoProcessTV

      THis is the internal error for SABnzbd : script_dir directory: /opt/sickbeard/autoProcessTV error accessing

      Any help is appreciated.
    • Did you try to copy the postprocessing scripts to a new folder and tell Sab to use them instead?

      Greetings
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.
    • Are you available tomorrow morning? Maybe I can assist you via Teamviewer directly.

      Greetings
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.
    • fixem2 wrote:

      Looking at the Sabnzbd folder config, it won't let me save the post-processing folder....GRRR!!


      This has been like this for awhile now. You have to stop Sab and edit he config file manually then restart Sab.

      What I am watching/watched on my Popcorn Hour media player
      omv 2.1.1 stoneburner | 64 bit | omvextrasorg 1.29
      MySQL (Percona) | Newznab | Sonarr | CP | HP | NZBget | YAMJ | CUPS
    • Source Code

      1. service sabnzbd stop
      2. sudo -u sabnzbd nano /home/sabnzbd/.sabnzbd/sabnzbd.ini

      then find the script_dir = line and add the link to the folder where the scripts are located, mine looks like this script_dir = /opt/sickbeard_mp4_automator

      Once done, press Ctrl+X this will exit nano but will first ask you to save the file, say yes (Y) and press enter for the name, you can now restart sabnzbd by running service sabnzbd start

      go back to the folders section in the configs and you should now see your location is set.

      What I am watching/watched on my Popcorn Hour media player
      omv 2.1.1 stoneburner | 64 bit | omvextrasorg 1.29
      MySQL (Percona) | Newznab | Sonarr | CP | HP | NZBget | YAMJ | CUPS