Can't mount newly created RAID 5

    • OMV 2.x
    • Can't mount newly created RAID 5

      Hi guys,
      I just came back to OMV from using Win Server 2012 for a while. I am really looking forward to using your NAS solution again, once I get it to work.
      This little project started tuesday evening, when I first noticed one of my WD Green 3TB disks had one of its SATA connectors broken. I was in tears, trying to figure out if I can fix the plastic piece of shit that fell off the god damn disk.

      Since wednesday, I've tried to stuff my other three disks into a RAID 5. Each time it's finished syncing, I try to mount it and I end up getting an error message reading the following:

      Failed to mount '43312270-ea1d-4006-9aa5-b7c33547663e': mount: wrong fs type, bad option, bad superblock on /dev/md0, missing codepage or helper program, or other error In some cases useful info is found in syslog - try dmesg | tail or so

      Error #6000:
      exception 'OMVException' with message 'Failed to mount '43312270-ea1d-4006-9aa5-b7c33547663e': mount: wrong fs type, bad option, bad superblock on /dev/md0,
      missing codepage or helper program, or other error
      In some cases useful info is found in syslog - try
      dmesg | tail or so
      ' in /usr/share/openmediavault/engined/module/fstab.inc:90
      Stack trace:
      #0 /usr/share/openmediavault/engined/rpc/config.inc(206): OMVModuleFsTab->startService()
      #1 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)
      #2 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      #3 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('applyChanges', Array, Array)
      #4 /usr/share/openmediavault/engined/rpc/filesystemmgmt.inc(899): OMVRpc::exec('Config', 'applyChanges', Array, Array)
      #5 [internal function]: OMVRpcServiceFileSystemMgmt->mount(Array, Array)
      #6 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      #7 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('mount', Array, Array)
      #8 /usr/sbin/omv-engined(500): OMVRpc::exec('FileSystemMgmt', 'mount', Array, Array, 1)
      #9 {main}


      This has happened each time I've re-created the RAID. This is the procedure: Install OMV, wipe data disks, create RAID, wait for it to finish, mount md0 filesystem, rinse and repeat.

      What is wrong with my filesystem and how can I fix it?
      Thanks and have a nice weekend!
    • So, I found a similar thread where a few requests of command output was posted.

      root@Rufus:~# cat /proc/mdstat
      Personalities : [raid6] [raid5] [raid4]
      md0 : active raid5 sdc[2] sdb[1] sda[0]
      5860270080 blocks super 1.2 level 5, 512k chunk, algorithm 2 [3/3] [UUU]

      unused devices: <none>

      root@Rufus:~# blkid
      /dev/sdd1: UUID="4311d1c8-9fa1-4d65-8d9f-cb3f60a6eff1" TYPE="ext4"
      /dev/sdd5: UUID="ef58893d-0243-4400-ba8f-35074f75eb33" TYPE="swap"
      /dev/sda: UUID="6d1f41a1-8f40-cb4c-1822-92207613df0c" UUID_SUB="82d469d9-64a2-5026-39d1-c42ecb187abf" LABEL="Rufus:Djingis" TYPE="linux_raid_member"
      /dev/sdb: UUID="6d1f41a1-8f40-cb4c-1822-92207613df0c" UUID_SUB="5203b7ef-6069-4840-1966-7cf9c20d3fca" LABEL="Rufus:Djingis" TYPE="linux_raid_member"
      /dev/sdc: UUID="6d1f41a1-8f40-cb4c-1822-92207613df0c" UUID_SUB="1e643951-7a49-6a58-7d07-68940cd168d2" LABEL="Rufus:Djingis" TYPE="linux_raid_member"
      /dev/md0: LABEL="Pool" UUID="43312270-ea1d-4006-9aa5-b7c33547663e" EXT_JOURNAL="00000500-0000-0000-0000-000000109982" TYPE="ext4"

      root@Rufus:~# cat /etc/fstab
      # /etc/fstab: static file system information.
      #
      # Use 'blkid' to print the universally unique identifier for a
      # device; this may be used with UUID= as a more robust way to name devices
      # that works even if disks are added and removed. See fstab(5).
      #
      # <file system> <mount point> <type> <options> <dump> <pass>
      # / was on /dev/sda1 during installation
      UUID=4311d1c8-9fa1-4d65-8d9f-cb3f60a6eff1 / ext4 errors=remount-ro 0 1
      # swap was on /dev/sda5 during installation
      UUID=ef58893d-0243-4400-ba8f-35074f75eb33 none swap sw 0 0
      /dev/sdb1 /media/usb0 auto rw,user,noauto 0 0
      # >>> [openmediavault]
      UUID=43312270-ea1d-4006-9aa5-b7c33547663e /media/43312270-ea1d-4006-9aa5-b7c33547663e ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,acl 0 2
      # <<< [openmediavault]

      root@Rufus:~# mount /dev/md0
      mount: wrong fs type, bad option, bad superblock on /dev/md0,
      missing codepage or helper program, or other error
      In some cases useful info is found in syslog - try
      dmesg | tail or so

      Not sure what other info might be required
    • Tried Ryecoaaron's option:

      Source Code

      1. dd if=/dev/zero of=/dev/md0 bs=512 count=10000
      2. mkfs.ext4 /dev/md0

      and then
      mount /dev/md0

      I had to delete the missing md0 FS in the OMV GUI but then, after a refresh, I could see the new FS and mount it.
      BLKID now shows no EXT_JOURNAL information and the FS has no label. Is this something I have to/can add?
    • A filesystem doesn't have to have a label but you can change it with e2label /dev/md0 "newlabel". Post the output of: dumpe2fs -h /dev/md0
      omv 4.1.23 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.15
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • That worked perfectly. Thanks!

      root@Rufus:~# dumpe2fs -h /dev/md0
      dumpe2fs 1.42.5 (29-Jul-2012)
      Filesystem volume name: Djingis
      Last mounted on: /media/c009fc86-0e28-48f0-be5a-14cf27259570
      Filesystem UUID: c009fc86-0e28-48f0-be5a-14cf27259570
      Filesystem magic number: 0xEF53
      Filesystem revision #: 1 (dynamic)
      Filesystem features: has_journal ext_attr resize_inode dir_index filetype needs_recovery extent flex_bg sparse_super large_file huge_file uninit_bg dir_nlink extra_isize
      Filesystem flags: signed_directory_hash
      Default mount options: user_xattr acl
      Filesystem state: clean
      Errors behavior: Continue
      Filesystem OS type: Linux
      Inode count: 183136256
      Block count: 1465067520
      Reserved block count: 73253376
      Free blocks: 1453461948
      Free inodes: 183135943
      First block: 0
      Block size: 4096
      Fragment size: 4096
      Reserved GDT blocks: 674
      Blocks per group: 32768
      Fragments per group: 32768
      Inodes per group: 4096
      Inode blocks per group: 256
      RAID stride: 128
      RAID stripe width: 256
      Flex block group size: 16
      Filesystem created: Fri Jan 8 10:10:37 2016
      Last mount time: Fri Jan 8 13:23:39 2016
      Last write time: Fri Jan 8 13:54:15 2016
      Mount count: 2
      Maximum mount count: -1
      Last checked: Fri Jan 8 10:10:37 2016
      Check interval: 0 (<none>)
      Lifetime writes: 17 GB
      Reserved blocks uid: 0 (user root)
      Reserved blocks gid: 0 (group root)
      First inode: 11
      Inode size: 256
      Required extra isize: 28
      Desired extra isize: 28
      Journal inode: 8
      Default directory hash: half_md4
      Directory Hash Seed: 4879cbd9-d8f4-4fc4-afc7-af0b09edff9d
      Journal backup: inode blocks
      Journalfunktioner: journal_incompat_revoke
      Journalstorlek: 128M
      Journallängd: 32768
      Journalsekvens: 0x00000787
      Journalstart: 1