Plex plays TV shows but won't play any movies

    • OMV 2.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Plex plays TV shows but won't play any movies

      I have Plex installed and working on my OMV box. It will read/launch/transcode/play all of my TV shows without issue on all of my client devices. If I try to play a movie, any movie, it won't play. On the client devices it gives an error basically saying playback timed out. I notice on the server GUI that it doesn't even pickup the request from the client (nothing is logged showing an incoming request for a movie stream, but if I simply back up, click on a TV show, and hit play it will work immediately).

      There is no difference between the files. They were all raw rips to MKV using the same software.

      Is this a permission issue? I already made a share for the root of each drive in my pool and reset permissions (a suggestion by Subzero elsewhere on the forum), but that did not help. I'm totally lost. Any ideas?

      The post was edited 1 time, last by Learning2NAS ().

    • Update: It's definitely not a permission problem. I've checked each folder, sub-folder, and a sample of files in the TV directory against those in the Movie directory. Everything is the same.

      The codecs for the files are all different (as MKV supports lots of file types inside the MKV container), but there is no consistency between the playable files and the non-playable files, other than length.
    • That's not correct.

      The article you sent me was for direct play on PS3, it begins by saying "Content matching the following can usually be Direct Played..."

      First, I'm not doing direct play, I'm transcodeing and playing. Second, MKV is supported by Plex. MKV is not a format, it's a container, so everything inside the MKV is the same old stuff that Plex is used to playing (MPEG2/MPEG4, MP3/MP4, AAC, DTS, etc). As I said, I am already able to play TV shows that are stored in these same MKV containers, but not movies for some reason. Additionally, I have tested playing the movie files on my old Plex Media Server and it will transcode to the PS3 without issue.

      Here are some screenshots, in case this is helpful to people.

      One is for a TV show that plays fine on all of my clients, including when it needs to be transcoded for the PS3. The other is a movie that doesn't play on any of my clients. I know the file is good because I can play it on my PC using VLC, but if I go through Plex or Emby, I get nothing.

      Just tried to stream to IE for the first time and, although the transcode still failed, it generated an error! That's great because now I have something to look in to. It says "Cannot Load M3U8".

      Does that mean anything to you?
      • TV.JPG

        54.03 kB, 834×208, viewed 965 times
      • Movie.JPG

        56.16 kB, 839×221, viewed 1,018 times
    • You're correct. I went over to the Plex forum and found this thread. They were having the exact same issue after a recent Plex update. It seems that the transcoding directory I had set in the Plex GUI was not being recognized (so my Plex transcoding was happeneing on my very tiny OS drive) and there was just enough space to do a TV show transcode, but not enough to do a full DVD or Blu-Ray.

      I have not yet resolved this issue, but it is not OMV related. I'll repartition or replace my OS drive with a larger one and try to transcode again. I'm almost certain this will resolve my problem.

      Thanks everyone!
    • I used the plugin, but reconfigured the database (using the Plugin GUI in OMV) and the transcode (using the GUI in Plex itself) directories. The transcode was happening on the wrong partition, or at least not on the partition I thought I told it to use, and so Plex was failing to get the job done.

      Rather than mucking around with the directory more, I just added 30GB of space to the partition Plex was using and it solved my issue :)
    • i guess i have the same Problem...i updated it to the newset plex pass version and now the plugin say's:

      Failed to get configuration (xpath=/config/services/plexmediaserver)

      Fehler #3003:
      exception 'OMVException' with message 'Failed to get configuration (xpath=/config/services/plexmediaserver)' in /usr/share/openmediavault/engined/module/
      Stack trace:
      #0 /usr/share/openmediavault/engined/rpc/ OMVModulePlexMediaServer->getStatus()
      #1 [internal function]: OMVRpcServiceServices->getStatus(Array, Array)
      #2 /usr/share/php/openmediavault/ call_user_func_array(Array, Array)
      #3 /usr/share/php/openmediavault/ OMVRpcServiceAbstract->callMethod('getStatus', Array, Array)
      #4 /usr/sbin/omv-engined(494): OMVRpc::exec('Services', 'getStatus', Array, Array, 1)
      #5 {main}
      HP-Proliant Microserver Gen8 | omv = always latest | 64 bit | 1x3TB ,3x4TB , 1x500GB HDD for Boot | omvextrasorg = latest | HP P212| Plugins = NUT, HWRaid, luksencryption OMV extras
    • The transcoding directory is one of the "advanced" settings. You'll have to open the Plex GUI and go to the server's transcoding settings, and then turn on the advanced option in the top right corner of the screen. It will then provide you with several additional configuration choices, one being the location for transcoding. Change that directory to the data drive you want to use, save, and reboot (for good measure).
    • I had a similar issue.

      I installed plex manually and after an upgrade to the latest version I could not play any video (the music was OK).

      So what I did is uninstall everything and delete any trace of Plex, reinstall again, but had no success.

      The I set on the server adjust, advanced options, transcoding, the proper path to the folder where I wanted Plex to do the transcoding and it started to play all videos again.

      Hope it can help someone else.

      Best regards.

      P.S. I will not upgrade anything unless it is mandatory to keep things working. As it is said: "If it works do not try to fix it up..."