Installing OMV 5 on Debian 10 minimal install problem

    • OMV 5.x (beta)
    • Installing OMV 5 on Debian 10 minimal install problem

      Ran into a few problems with a virtual install...

      Installed Debian 10 from the netinst ISO as I've always done before. During the install when it came time to install packages... I unchecked everything except SSH server, as I always have...

      Install finished, SSH no problem... then I followed the instructions in the guide. forum.openmediavault.org/index…OMV5-on-Debian-10-Buster/

      The first command ran no problem (add the repo).

      The second one, errors out on a couple issues.

      1. It appears on a minimal Debian 10 install, gnupg and wget is not installed, this causes the 2nd command to fail as it can't fetch the omv key. apt install gnupg2 wget and running the 2nd box again, should handle this problem

      2. For some reason, the key still doesn't get fetched after gnupg is installed. grabbed it manually wget packages.openmediavault.org/public/archive.key and then apt-key add archive.key to resolve this issue

      At that point, I can copy/paste the 2nd box, and the procedure continues like it always has previously.

      I thought maybe something got missed by not installing "Standard System Utilities"... during the Debian Install (even though I never recalled installing this before)... so just for grins, I did another install, this time only installing SSH and Standard System Utilities.... On this install, wget is installed, but gnupg is still not installed. So the 2nd box fails again. I then have to install gnupg, manually fetch and install the key... then the 2nd window runs no problem and installs OMV 5.
      Air Conditioners are a lot like PC's... They work great until you open Windows.

    • Thank you KM0201.
      I got a lot further with you help. So i did the following (in that order:

      login as su

      copy & paste Box 1

      Source Code

      1. apt install gnupg2
      2. apt install wget (didnt work, was already installed)
      3. wget packages.openmediavault.org/public/archive.key
      4. apt-key add archive.key


      copy & paste Box 2

      Then i got some warnings and errors.

      no IPv6 possible and the following:
      pastebin.com/UT0xUFMe

      But the main information:

      Its looks like the first time OMV 5 on RPI4 (4GB) without any errors!
      Great!

      The post was edited 8 times, last by oberfragger ().